Please read: make it easier to help you

Welcome to the Julia Discourse! We are enthusiastic about helping Julia programmers, both beginner and experienced. This public service announcement (PSA) outlines best practices when asking for help. Following these points makes it easier for us to help you and more likely you’ll get a prompt, useful answer.

Keywords are highlighted to make it easier to refer to specific points.

  1. Choose a descriptive title that captures the key part of your question, eg “plots with multiple axes” instead of something generic like “help me with plotting”. Make use of tags and categories (you can edit those and the title after posting). These will make it more likely that your question will be seen by the people who can potentially help.

  2. Post quoted code by enclosing code blocks in triple-backticks ```:

    function f(x, y)
        x + y

    This will highlight syntax and use a monospace font.

    Don’t post your code as a screenshot; it is difficult to read and impossible to copy-paste.

  3. Indent your code to reflect its structure (your editor should help you with this). Indented code is easier to understand and troubleshoot.

  4. Do your best to make your example self-contained (“minimal working example”, MWE), so that it runs (or gets to the error that you want help with) as is. This means including package loading (e.g. using ThatPackage) and any data that the code operates on. If your data is large or proprietary, generate example data if possible and include that. This StackOverflow answer explains how a DataFrame can be turned into a string representation that can be copy/pasted.

  5. Simplify your code to the smallest piece of code that still shows your problem. This step takes the most effort but is the most important for fixing your problem. Short, simple examples tend to get answers quickly.

  6. Include code instead of REPL output, except when the latter is relevant. (REPL is “read-evaluate-print loop”, the julia> command line.)

  7. Include full stacktraces (that is all of the stuff that comes along with an error message). They often contain valuable information, even if they seem cryptic. Please quote the stacktrace as well (see point 2).

  8. Please use the latest stable version of Julia and released packages (you can ensure the latter with pkg> up). If you cannot do so, make sure you note the relevant versions by including the quoted output of versioninfo() and pkg> st --manifest SomePackage.

  9. If you have a plotting (style) question, include a plot with the desired output (possibly generated with other software).

  10. You may not get a response here for packages with a very narrow audience. In that case, you may want to consider opening an issue on Github (or Gitlab, etc) for the package repository, just to ask a question. Most packages are OK with this.

  11. If an answer solves your problem, mark it as solved by clicking the “:white_check_mark: Solution” button. This makes it easier for future help-seekers to find the correct answer, especially in a long discussion.

  12. Avoid extending the original question that has already been answered with many new questions. It is better to start a new thread.

Simple type question
Saving JUMPArray to JLD or JLD2 file
Mixed Type Variables in Julia
Can't understand numerical errors on julia
Format x-labels using VegaLite
Correct constraint statement
Julia integral calculation - community module or own module?
Help with Logit NLP problem
Distributed Simulations
How to use DifferentialEquations with complicated equations
Enum not at top level expression
Waveform Characterization
Keyword function error inverts position of arguments?
How to efficiently splat values into argument list?
Downsides to depending `mutable` field on `DataType`?
Linking subplot x-axes containing dates
Plotting with JuMP variables
The "sum" in constraint
Newbie question regarding opening files
Type instability in array concatenation
Flux.jl Inconsistent Training on Custom Architecture
Unitful + ForwardDiff
Use of MINLP in Julia
Why is a type when used as a function given a boolean true return a number?
How to upgrade code for a symmetric distance matrix from julia-1.0 to julia-1.6
Annotation to figure with 2 Subplots
I need to convert these parallel robot algorithms to Julia from Matlab, but I cannot get the forward kinematics to work
C++ code much faster than Julia how can I optimize it?
Updating Old Julia Code - Cant get past ArgumentError: Invalid Index
Show right y-axis using twinx() with Plots pyplot()
Why doesn't this code work? I can't figure out
Updating Old Julia Code - Cant get past ArgumentError: Invalid Index
Trying to use quadprog function from MathProgBase, has error "no method matching"
Question on use of include from 0.6 -- 1.0
Weird duplicated entries with different values in SparseMatrixCSC
Why do Rationals promote to Floats
Plots and truncating numbers?
Can we use Openslide or do we have a tool to open MRXS files from microscope?
Nan Error in CSV
Julia's processing capacity
Problem visualizing x-axis' ticks on a plot
How to pass on kwargs? - updated
Linking subplot x-axes containing dates
The photo is from a Python code so how could I have the same result in Julia?
Nonlinear curve fitting with weights with LsqFit
Loading image using julia
Getting Gap and #Nodes in JuMP v0.19
Initialization of an empty array, which will be filled in a loop with arrays of different sizes
3D plotting packages
Position of plots on the screen, Plots.jl ,gr()
Better editor placeholder text
Julia silently stop working while computing the rank of some not that big matrix
How do I fit generalised linear multilevel models including offsets?
How do I fit generalised linear multilevel models including offsets?
Array of functions - is there a way to avoid allocations performance penalty?
Differential Equation Parameter Estimation Using Only A Subset of Variables
MethodError: no method matching floatrange when running histogram. 1.7.0 Win 11 21H2 AMD 5900Hx
Significance of global keyword
Question ) Mathematical equivalence, but different results of fixed point?
Performance of Memory Mapped Arrays (vs. JLD2)
Array definition error
Can the compiler automatically optimize this code?
@time is off by at least 10x
Using JuMP to solve the heat equation - performance tips requested
Plots package install error
Custom likelihoods in Turing.jl
Unexpected Type conversion
Question about matrix
SharedArrays. Stability
If f = +, why can't I use f as an infix operator (e.g., 2 f 3 == 5)?
The mean of 3-d EmsembleSolution from StochasticDelayDiffEq
I'm blind again, how to supress subplot annotations?
Newton method in PowerModels.jl
Switch from HttpServer.jl to HTTP.jl
Modify a dictionary under a new name modifies the original dictionary
Calling julia functions from python
What am I doing wrong, I can't use Julia with jupyterlab?
Translation groupby and agg and join python to julia
Correlation Matrix vs Contingency Table
Pointer error
How to edit row values of a dataframe column based on condition using query.jl
Error with Cairo and Fontconfig
Different results between Zygote, ForwardDiff, and ReverseDiff
Difficulties with parametric plots
Create a Package
How to use ForwardDiff with NLopt?
Confused about Dimension Mismatch
Equality Constraint format in NLopt
How to use interior point algorithm in GLPK
Help speed up the function
ERROR: syntax: ssavalue with no def
CUDA doesn't work
Where is the graphics documentation
How to pass command line arguments to include("<julia file>")?
How to plot columns of a matrix on a single line graph in Julia
Parallelizing function returns no output
Minimizing a numerical function
Simple Vector - UndefVar Error
How to realize this multithreading function
ForwardDiff evaluation of objective in Optim returns wrong result (objective uses DifferentialEquations pkg)
What does it mean x=-3:0.1:3?
Flow conservation constraint
On moderation and edits
Looped optimization model
Import package from python
Julia falling asleep during optimization (blackboxoptim)
Testing a package with runtests.jl does not generate graphical outputs
A usage about multi-dimension arrays
Function change
Pmap results in Array of type Any
A problem with SOCP constraint
Applicationerror: solver (gurobi) did not exit normally
Problem with trivial arithmetic
Performance of Dict
Julia stops unexpectedly (after 10 mins of use)
Logical processes remain active after my parallelized program ends
How to use the error "provide a valid sink argument"
Convert array to dictionary
AmplNLWriter, NLexpression, can't evaluate pow('(0,0.45),
How avoid this Warning when I use Contour
Trying to require Modules in a circular way, program just crashes
Is there a way to suppress "method overwritten" warnings?
Variable reference in a function created by a macro
ExcelReaders issue never happened before
Help Couenne
A problem with SOCP constraint
Slow runtime when assigning struct reference
Method Madness
Weave with PyPlot.jl
Getting different output for fft function in julia and matlab
CUDAnative support for Float16
Problem calling string parse + eval from C++
Iterating using Channel
Problems updating from JuMP 0.21.4 to 0.21.5
Import xlsx file
MWE - setindex bug?
Unnecessary compilation happening on every call
GLM: "no method matching fit"
GLM: "no method matching fit"
Rules when box/unbox applies
Gradient of a normal (NOT vector) function that has vector arguments
Read/write compressed files in julia 0.7
NLSolve vs fsolve (matlab): What am I doing wrong?
Scale is not defined
Get results from CBC solver for optimization
How to attach the result of Julia REPL? (using vim & tmux)
Large size of plot files generated using Plots.jl with GR backend
Include .jl file
Beginner: LoadError: InexactError: trunc..when convert dataframe
String Indexing - Alright, what am I missing?
syntax: missing last argument in "2:" range expression when using include("MyModule.jl")
Julia is slow questions - how to request information
If-else applied to a DataFrame
Library for (algebraically) complicated sums (and other expressions)?
How to use Dagger.jl's blocks to read a multifile NCDataset?
Optimizing a function with constraints in NLopt (want a different expression returned than optimized)
Use square brackets [] for indexing an Array
Initialise array without specific types
Mmap.mmap leaves the file open
How to replace macro argument with expr as being typed manually?
LoadError: MethodError: Cannot `convert` an object of type Array{Float64,2} to an object of type EasyFITS.FitsImage{Float64,2}
JuMP Error: "Unexpected object missing in nonlinear expression"
How to solve Ax=b, with A,x,b are matrix
Sortperm slow test case and fix suggestion
Constraint MINLP problem
Julia appending data to dataframe gives dataframe not defined
Delete rows that exist in another data frame in Julia?
Trouble creating a real-valued vector out of elements of multiple complex arrays
Plot, set a color to a smooth line?
Comparing Unequal Dictionaries
I need your Help!
Fast way to Implement a Loop
Inserting global list to a function, change the global list
Interesting problem with where parameters
Simple way to save several variables
Delaration of an array with indexed type
SOS use on multidimensional arrays
Getvalue() help
Warmstarting variables does not work with Xpress
JuliaDB won't open CSV file
Running for loop in parallel and appending result to vector
MDPs simple program which:
help converting JuMPArray to regular array
StackOverflowError with julia v1.1 similar to previous bug v0.7
Error Travis Julia form GitHub Repository -- ERROR: KeyError: key "git-tree-sha1" not found
PyCall and ExcelReaders error
Got a looping of "warning: replacing module myModule"
Issue when Converting object of Type day to year
while loop unexpected behaviour (at least for me :) )
Writedlm gives wrong output
JuMP: filtering the output of JuMP.value.(x)
Large sum returns negative numbers in julia
Detection probability
How does setrounding work?
Zygote.gradient(): Mutating arrays is not supported
Provide a specific argument to a specific function from a series of functions from command line
SymPy function with 2 variables
Non-allocating A / B where A and B are matrices
CPLEX - Setting branching priority
Deleting containerized constraints
How to sample a Data frame
OutOfMemoryError()_solved by sparse matrix
CAS benchmarks (Symbolics.jl and Maxima)
Modelling DFJ elminations constraints
Concatenating vectors
Animation fails in frame()
Indexing a const array with a JuMP variable
How to change the RHS for a set of constraints and solve the problem iteratively using JuMP?
Vector affine function with SOC not supported in JuMP (.18 -> .19 breaking change?)
How to extend SecondOrderODEProblem in DifferentialEquations.jl?
Numerical Accuracy of the Solver
Organizing code into functions—am I doing it right?
MethodError: no method matching -(::LinearAlgebra
Help with two Julia lines of code whose syntax is unclear to me
Iterative feedback and discussion on the pinned "make it easier to help you" topic
Error in ploting
JuMP - variable constraint depending on variable
How to write conditional expression using JuMP
Filter out the nonzero values in a dense axis array
Error type mismatch
Running into a deprecation while assigning variables and constraints in JuMP (v0.18.5) on Julia (0.7.0)
Strange deadlock in 1.7.0-beta3 didn't happen in 1.5.x
Parallel run in for loop
Map over namedtuple keys and values: confusing error
What wrong in cat ? Two simillar Arrays! ERROR: UndefRefError: access to undefined reference
Optim: MethodError: no method matching zero
Unusual slow Julia code compared to C++?
How does setrounding work?
Problem in @NLobjective
Steps to create additional table on matrix
Error in plotting the graph
How to use the iterator with strings with NamedTuple?
Error: function undefined
Entering xlsx columns into HypothosisTests
Ink package atom
GPU - CLArrays, GPUArrays - Extract a Matrix from an Array
Updating Julia has broken scatter plots
Getobjective does not return value of my objective function
Rand() doesn't work for NormalInverseGaussian
Getting this error Message MethodError: no method matching getindex(::DataFrame, ::String) but method is there (I m trying to do the kaggle dataset "" )
ForwardDiff & mul!()
Comparison between time taken in Python and Julia
How to use "plotyy" for showing several sets of graphs in one plot
Optimization problem
UndefVarError: ClpSolver not defined
Hi. Trying to add Julia to the PATH on my Mac Book Pro.
Cannot add StatsBase package, getting GitError
NLopt failed due to Forced Stop
Running in world age ... while current world is
Best way to extract parts of arrays in a bigger array
Problem with SPICE package installation
Trouble importing a module that depends on another globally imported module
Scope when using multiple modules
Converting a Vector{float64} to float{64}
Images.jl not working with JuMP output in for loop
Can I get variable value during the optimization JuMP.value?
ML feature importance in julia
Predict fails for simple case of GLM?
Unable to optimize using Alpine.jl
How to solve large sparse LPs in Gurobi
Const FileData = AbstractVector{UInt8}
Confusion on DifferentialEquations.jl. How many saved timesteps
Is there Julia library for AI Image Denoising?
Problems with Diagonal from LinearAlgebra
MethodError: no method matching -(::VariableRef, ::Nothing)
Kernel Compilation error- KernelError: recursion is currently not supported
How to convert CartesianIndex{N} values to Int64
How to read big data chunk by chunk(column-wise chunking)?
Dual{::ForwardDiff...} type error when JuMP tries autodiff User-defined Function
Iterative feedback and discussion on the pinned "make it easier to help you" topic
Error in Cuda function : ERROR: LoadError: CuError(1, nothing)
@formula for Lathe.preprocess UndefVarError
Optimisation design advice - metaprogramming/closures
How to Calculate and Plot Fit Residuals from Numerical Integration to High Precision
Use of std function in Statistics
Julia plot not saved properly
For loop error
Makie interaction: Slider with animation
LP Warm Starts - using Gurobi with JuMP
Error in Array
Type NamedTuple has no field id
Task termination
How can I use Zygote to get the gradient
Matrix multiplication with custom types
How to fill dataframe from an array and date range?
Reading complex text files with vectors
Mapping using GMT syntax
Any one can help me on this code
Couenne no results - seems stuck
Read and write/save 3-D image
Difference in sparsity pattern caused by @NLconstraint and @constraint in JuMP
Does julia has a Package designed to / for sparse matrix
Optim constrained optimization issues
Error with building NLexpression in JuMP 0.19.2
Function zero() with type"Any"
Is there @code_warntype output documentation anywhere?
Using sparse matrix in NLoptimization
Function does not work as expected
ANN: DynamicHMC 2.0
"using" keyword in Julia
For loop Performance
Unable to install Pyplot package
Multiple dimensional sampling with first element string
[ANN] Write Excel files with XLSX.jl v0.2.0
How to view which of your binary values are 1
Add incoming data to a DataFrame
Multiple amount of summations in JuMP
Optim.jl is installed successfully, but "optimize" function is not inside, nor other functions!
Type FPFunctionalCache has no field caches error
Help to set a penalty
Merging dictionaries indexed by elements of struct type
Restrict type of value type parameter
Solving system of equations
ERROR: [Turing] MH doesn't support vectorizing assume statement
Help with CSV and Dataframe
How to make EvoTrees.jl more performant?
Met a weird error; UndefVarError
Array{Float64}(undef, X) gives wrong results
Trouble with hosting. What am I doing wrong?
Implement case_when in Queryverse
Basic writing to file question(s)
How to export Julia data to a .CSV
Output matrix in last (t-1) generation: normal; Indexing the same matrix in this generation: NaNs in the (t-1) column
Understanding mutating functions correctly
Fast calculation of eigenvalues
Program structure
Getting error while using CurricularAnalytics
How to use ForwardDiff.GradientConfig for multiple input functions while calculating gradients in parallel
Having problem with Convex.jl
Function defined as multidimensional integral
Importing modules that depend on modules
ArgumentError: no outer repetition count may be negative; got (-1,)
Loops "for" and "while" in JuMP
Why it is so slow to factor(BigInt) by Primes?
Please help me with my optimal power flow problem
Creating custom indices (or Range?) from a set of arrays
Problem defining a Neural Network with gradient as Loss function
Face this run time error
Sorting a sparse axis array in JuMP
Understanding how HTTP works
User's input
Base.getfield() gives warntype?
MethodError: no method matching isless(::Int64, ::Array{UnitRange{Int64},1})
Code execution problem
Improving Performance of this Code
Save Array of Arrays in HDF5
Simplify MINLP problem to speed up results
How can I implement this equation?
Bounds error for MINST training
Solve many first-order ODEs
Output in VSCode
BoundsError when solving non linear system of equations
MethodError: no method matching similar_array_type
Julia: from total beginner to power user (youtube channel)
Error installing ImageView Library
Help with gradient
How would I convert the key value pairs of an accumulator data structure to a dataframe
@timed to plot the time and memory consumption
Declare two exceptions in an equation
Getting output after solver timeout reached
Shared definitions across modules
Converting array to a vector
Gsub function in Julia
Trouble with @eval with mixed variable scopes
How can I plot a choropleth map from a dataframe?
Calculating a standardization function from scratch
I do not understand this error: MethodError: no method matching iterate(::DataFrame)
How can I plot a choropleth map from a dataframe?
The error of using GLPKMathProgInterface pkg
Arrays, Matrix, append!
Warning for adding constraints: zero or small (< 1e-13) coefficients, ignored
Warning for adding constraints: zero or small (< 1e-13) coefficients, ignored
Restoration phase failed
Linear programming with Jump
Specifying StaticArray Types
Kmeans problem
The error of using GLPKMathProgInterface pkg
Pde heat diffusion solution
ERROR: LoadError: UndefRefError: access to undefined reference
Why "Threads.@threads for " doesn't use all possible threads?
How can I add a legend
I wanted to plot Graphs in Jullia (IntellijIdea)
ArgumentError y = [y;df[:,Symbol(v)]]
How to add norm of gradient to a loss function?
I have no idea what's wrong. Please help! ERROR: UndefVarError: i not defined
Zygote gradient Error
How to set @variable(m, tau[1:N] >0 ) with JuMP
BitArray{3} mesh
How to solve this problem with T
Channels and Conditions: How to do notify channel is ready
Updating a plot
Turing.jl run not reproducible!
Populate a Dataframe from an array
Entrys with Gtk
Pca question
Running simulations over range of parameters
A newbie can not use CUDA by follow official DOC!
Opening and reading text: why does Julia insert many "\"
Debugging of julia modules lead to errors while evaluating not
Array variable - matrix multplication in JuMP
Deferred-shape arrays
Initializing a dataframe
Running Julia script with predefined environment
How can i Decode this Data?
DataFrame vs. Pandas (vs. Excel...), e.g. to refer to previous row
A question about Atom/Julia
DataFrame vs. Pandas (vs. Excel...), e.g. to refer to previous row
Warning, invalid warm-start basis discarded
I want to implement a normal log in julia and i'm new in and don't know how to do it
Method works in REPL; can't use in a function body
Modules and files
Memory Allocation JuMP constraint!
Gadfly label coloring
Writing data to csv
Problem in attaching array type in struct
A implementation of ResNet-18 uses lot of GPU memory
Segmentation fault when trying to make a custom sysimage
Moving from LMI toolbox (Matlab) to JuliaOpt
Stipple error in German credit demo
Get One-On-One Help
Question regarding COSMO Convergence
Garbage collection
Why does Julia think a vector is a string?
MethodError: no method matching getindex(::Nothing, ::String)
Using multiple dispatch with parametric constructors produces ambiguous call
Problem Lambdifying atan function
Simulated annealing Algorithm
Converting from Shell to Julia
MLJFlux is a lot slower than the same algorithm written in Flux
Save figures as pdf
Batch size and early stopping in Flux
Need help writing some recursive code please! Full code explanation and snapshot included
Stochastic simulation error
Trouble plotting grouped data (VegaLite.jl)
Parrallel programming
Why does Julia think a vector is a string?
Histogram Equalization
Question about my Pkg
ERROR: LoadError: LoadError: UndefVarError: n_actions not defined
How do I speed this up?
Clear variable?
Point wise operations on array of vectors
Julia can't precompile various packages
Love Julia, but..... Type hierarchy is frustrating
How to uninstall properly Julia under Unbuntu 14.04 LTS
List comprehension in Zygote
Using Flux to optimize a function of the Singular Values
Problem with Mutating array not supported in constructing a Wasserstein GAN in Flux
Readdlm command issue
Cleaning information to solve multiple instances of a JuMP model
LinearMap : error while running LinearMap
Different plotly behavour across computers
PyError. Can't use ExcelReaders
Data Collection Issue With Julia Agents
Regex numeric range generator
The conflict of variables using @build_constraint
Conv_mnist model-zoo example,
On OS X Catalina, running 'solve' in DifferentialEquations causes crash
Turn code into function
Undefined /out of scope
Its possible to use all cores or parallel cores to do some project/calculations?
Undefined /out of scope
"plot not defined" and / or "twinx not defined"
Error Unsatisfiable requirements detected for package ZMQ [c2297ded] when adding new packages
Good examples of posts asking questions
Made Julia quit and now won't run even after re-install
Can't install Gadfly - unsatisfiable requirements detected
CUDA on Julia 1.7 giving wrong results
UndefVarError: ncounter
How to plot and save figure, by running code on unix server
Which optimization package should I use?
Parallel computing of matrix with @threads
Changing the z-scale in plots3d
Pde heat diffusion solution
JuMP conditional constraint
How to export this type of vector
“using” expression not at top level
List comprehension of JuMP variables
LMI, Control system, Robust Control Adaptive Controller
ForwardDiff: Error ForwardDiff.Tag How to transform a Dual Type to a Float
I am new to Julia, could someone help me to check the code?
Not sure how to get this LsqFit working
Differences in MATLAB's versus Julia's beta(x, y) for large x or y?
User-defined objective function with scalar and vector inputs
How to add text to a rendering?
Homework policy
Optimization with Optim gives different results each time
How to pass on kwargs? - updated
Plots.jl how to create a heat map from several curves
Where to find tutors for Julia?
Can not choose alg for lyapunovspectrum DynamicalSystems.jl
Its possible to use all cores or parallel cores to do some project/calculations?
CairoMakie returning empty plots
Modify FASTQ file description with a new string using FASTX
Reduce and sum Value ( frequency matrix)
Searchsortedfirst `by` argument not working?
Variables declaration in JuliaPro 1.5.2-1
Delay in processing
"for" loop, collect()
How to deal with Julia Out of memory problem
Path Environments
Weave won't convert a tex to pdf, because it says the directory is not empty
ForwardDiff with function using broadcasting
Plots: bars side by side
Readtable function
Help with macro to construct truth tables
How does Julia merge several exprs to one expr?
Intersect of 2 arrays
Evaluation into the closed module `__anon__` breaks incremental compilation because the side effects will not be permanent
How do I write @variable(z=x[1]+x[2])?
Query root relaxation values with JuMP
Slider of a point in a graph
Meta-programming an if-else statement of user-defined length
Bridging Slack's #Helpdesk and Discourse (Proposal, feedback welcome!)
On moderation and edits
Alternative to computation in a loop for distances for fast performance
Rules when box/unbox applies
Computing Flux.gradient change the model
Mesh3D Only Plotting Half
Three state variable
How to export `Base:@kwdef`?
L-BFGS returns a NaN gradient when providing analytical gradient. BFGS shows no issues
Vector function representation
Converting CSV string values to floats (Python to Julia)
How do I distribute Mamba mcmc function iterations on different processors?
Jupyter Won't Spawn ENOENT, unable to export pdf
Plotting implicit functions
Reading text or csv files and assigning values to variable names
@everywhere and Dictionaries
No method matching iterate(::XLSX.Worksheet)
Concatenating vectors of different length into a dataframe or table
How to attach the result of Julia REPL? (using vim & tmux)
JLD load error for Dict
Binary classification with Flux
Set_start_value in JuMP for SCIP
Change default JULIA Path Manually in Ubuntu
Contents of the function run well when timed alone, but not when they are in a loop inside the function
How to improve runtime with measurements.jl?
Julia code for 1-D discrete system
Plotting broken? Gadfly and Plots backends not showing axis ticks, can't plot DataFrames
Iterative feedback and discussion on the pinned "make it easier to help you" topic
Using Julia to solve semidefinite programming problem that has vector solutions
Optimizer returns status infeasible for a feasible problem
Using Julia to solve the student final project allocation problem
Colon / Ranges
Increase performance in string comparison with sub-dataframes or sub-arrays
Animating 10 steps
How can I use optim.jl to find some values
Which solver/model library can be used recursively / reentrantly
Autograd in Flux
Bug in julia zeros() side effects
Linear regression from scratch using QR decomposition
Local arrays in for loops
DifferentialEquations.jl: Complex function results in Inexact Error
Flux unroll
MOSEK fatal error stopenv
Iterating over row in a DataFrame
RNN Not learning
Threads, @spawn on Mac - inconsistent behavior
Optim - provide gradient with fixed parameters
Simple Linear Regression: Domain Error with 0.0
NLopt not optimising
Gurobi constraint
How to avoid supplying exact types in a Dict constructor?
Model Predictive Controller only works for certain values
Error while trying to download the Distributions Package on JuliaPro
No method matching zero(::Type{Array{Float64,2}})
Indexes and multidimensional arrays
Performance of log in nonlinear optimization
I can't load RDatasets in Julia
BoundsError: attempt to access 5×100 Array{Float32,2} at index [[0, 5, … 490, 495]]
Julia not able to convert Array to a series data for plotting
Julia Complex Exponential Evaluation vs Matlab
BoundsError on Bayesian ODE model with Turing
Makie Observables
Mutate Zygote Gradients with a Custom Mask Before Update?
UDP receive and send with julia
Speed up matrix multiplication with permuted vector
Tricky interpolation issue
Gurobi with StochasticPrograms.jl
How does Pluto decide what to show graphically?
Vcat and plot behavior inside Julia script
Julia contour lines issue
Precompiling most packages fails in Atom/Juno with 1.6.0
How to record the optimization process when using the JuMP optimization package for optimization
Unexpected ERROR: UndefVarError: a not defined
Maximize Min Objective
Indexing vector elements of a matrix
No method matching loss_multiple_shooting
How can loop through a image folder?
Disassociate parameter or variable from a model in JuMP
Finding all rows that are the same as a "focus" row
The plot command moves the graph
Multithread on JuMP for Benders cut
CBC solver
Plot data on Map with GMT.jl
I have problem with sampling Frequency when I use ACME.jl
What is meaning of M1, rpath?
Constraint declaration generates an error
UDP receive and send with julia
How to use pmap with DrWatson
Use a String For a Variable name and convert Dictionaries to DataFrames
Pwd() cd() and I/O text for open files from pc
Jacobian matrix
Layout pv panel optimization
How to write matrix data to Excel in separate worksheets?
How to add a constraint with neural network in a JuMP (PowerModels) model
How to parallelize within a function
Handling of package inter-dependency
Lasso Regression of Matrix of Vectors
@time and @benchmark give different results
Layout pv panel optimization
Change the constraints name iteratively to JUMP model
Optimization with JuMP and KNITRO
Wondering Why the Variable is Not Used
Problem with lyap(Q,R)
Using to import data from a data input file into a DataFrame
Handling of package inter-dependency
Using Loop
Using Loop
Using variable names to parse DataFrame
Surface command in Julia
Strange nan errors when mutating immutable struct arrays
Julia sum issue
DifferentialEquationsjl with ForwardDiff.jl
How to convert a multivariable polynomial with integer coefficients to one with Float64 coefficients?
Solve(ode, Tsit5()) throws "Possible method error" in VS Code
Mesh grid in Julia
ODE with vector Argument
Confusing dimension mismatch error
Getting NaN output from JuMP variable after solving
Indirect Connected vertices in a digraph
Best way to define a set of differential equations?
Using ```set_state```?
LinearAlgebra: rank
Memcpy in julia
Get a picture icon when I try to plot a histogram
Coding up basic power flow equation
Questions about Polyester.jl
How do I have to read an unknown number of floats in binary data till EOF?
Makie Animation
Found Bug in Flux
Problem with implementing the objective function with minimum and maximum functions simultaneously!
Parallelization of Sum in JuMP
Infeasible or unbounded model
Cholesky simple example
Struct initialization error
Why is this code wrong?
How can I transform this matlab code into Julia
Using Debugger in Julia 1.6.3
Converting Missing to Date
Julia Manual GMM
Apply some functions to columns of a dataframe
Using JuMP to solve the heat equation - performance tips requested
TypeError: in typeassert in Julia 1.6.3
Dummy variable change optimization result
Local infeasibility, Ipopt
Cannot use the Collections module
Solving MPC using JuMP and Gurobi
Problem using ```lyapunov spectrum```
Problems on Flux.destructure()
A question about Distances.jl
"contains" as operator?
Appending rows to a dataframe is seemingly inconsistent and confusing
Why doesn't method dispatch work on the same candidate included from different sources?
Make "Please read" post a pop up in new threads
How to use the solver-dependent callback
Updating an old model and running into deprecation and getting errors I have fixed a lot, tic toc problem here what is the best solution to replace?
A problem with JuMP Tutorial-linear problem-cannery problem
How to load a portion of image dataset
Julia stopped working
Organize the output of a mathematical model
Help to correct this code please
Error on installation packages
Simple Linear Regression: Domain Error with 0.0
Problem with Plots
Compute gradient of gradient norm using zygote
Buffer in running external program in loops
Ploting data
Two stage stochastic
GLMakie - Connecting a Slider to update images in an axis
Dependencies "4 skipped during auto due to previous errors"
Can we find a DDe's canstant from a table
Defining constraint using JuMP convert String to Expression and Merge Quart Expr and nonlinear Expr
How to control type conversion from python to julia
Converting PyTorch to Flux while keeping performance
Unexpected change of a function argument (array) - bug or feature?
`ReadOnlyMemoryError` in PyCall
Dynare - "LoadError: InexactError: Int64(NaN)" for the simplest model
Issues with abm visualization
Regarding use of Max in Jump code
Converting Dense Axis array results into dataframe
Nlsolve for find root for a system of ODE for an implicit runge kutta method
Performance slowdown on AMD with Windows10 compared to Intel with Linux (arch)
Radial Basis interpolation multivariable
Complementarity.jl supports equality constraints?
Clustering.jl Silhouettes Distances
Error message when using AoG/Makie with "yscale=log10", for my particular data
Defining constraint using JuMP convert String to Expression and Merge Quart Expr and nonlinear Expr
Nlsolve for find root for a system of ODE for an implicit runge kutta method
Parallel programming loops
Nonlinear solver other than IPOPT
Percentages in pie plot
Using CellListMap.jl within Agents.jl framework
Instances for type
How to make a model applicable to Turing.jl?
How to write a constraint Julia-jump
How to convert fmpq to Int
Errors in inference in upgraded Julia version (1.6.3 vs. 1.7.3)
MultivariateStats (PCA)
UndefVarError: DataLoader not defined
Finding Derivative of 2 arrays of numbers Using Zygote
What is sympy (python) equivalent differentiation method in Julia?
Another question on eachoverlap in GenomicFeatures.jl
Save and restore namespace
Bounds error while iterating over for loop
How to solve this error? About Pkg.jl and Plots.jl
Plot exponential fit
Multivariate nonlinear constrained optimization using JuMP and ForwardDiff (Automatic Differentiation)
Type compare
How to convert code from python to julia. the magic squares
Help on Lotka Voltera model Parameter Estimation
Julia pmap how to write each worker into separate index using parallel computing
I Need help with DiffEqFlux
Code Generation
Optim.jl: bracketing with Newton()
Use of variable in Julia REPL
Coalesce function not working with data frames n x n with n>=2
Preallocating large matrices in all cores is slower than allocating every time
ERROR: LoadError: syntax: invalid identifier name "&&"
Plot limit at next tick label
JuMP : not getting the correct solution of the optimization problem
Suppress Plot Window when output to animation
Optimize not working with function that has find_zero
How to undershand the Objective goes greater while itering?
JuMP problem with all_variables
Problem With Integer Stack Size

99 posts were split to a new topic: Iterative feedback and discussion on the pinned “make it easier to help you” topic

2 posts were split to a new topic: Suggestion for concept maps

A post was split to a new topic: Better editor placeholder text

This post was temporarily hidden by the community for possibly being off-topic, inappropriate, or spammy.