Optimization with JuMP and KNITRO

Hey everyone, I was trying to do a non-linear optimization problem with KNITRO. The JuMP model seems fine:

A JuMP Model
Minimization problem with:
Variables: 270
Objective function type: GenericQuadExpr{Float64,VariableRef}
`GenericAffExpr{Float64,VariableRef}`-in-`MathOptInterface.GreaterThan{Float64}`: 83 constraints
`GenericAffExpr{Float64,VariableRef}`-in-`MathOptInterface.LessThan{Float64}`: 105 constraints
`GenericQuadExpr{Float64,VariableRef}`-in-`MathOptInterface.GreaterThan{Float64}`: 90 constraints
`GenericQuadExpr{Float64,VariableRef}`-in-`MathOptInterface.LessThan{Float64}`: 90 constraints
`VariableRef`-in-`MathOptInterface.ZeroOne`: 270 constraints
Nonlinear: 120 constraints
Model mode: AUTOMATIC
CachingOptimizer state: EMPTY_OPTIMIZER
Solver name: Knitro

But when I ran optimize!(model), it seemed that KNITRO was not called and the optimization problem was not solved. KNITRO is installed here and for simple top problem, it works well. Is there anyone knowing what the problem might be? Thank you so much!

Can you post the whole code or a MWE?

1 Like

Hi there! Since it’s your first post, please read: Please read: make it easier to help you. It has some advice on how to write a good question.