Pkg.add("ImageView") fails on Win 32 bit system for V1.6 V1.8 V1.9

Other packages work FileIO,ImageIO but ImageView 2 items left over

Can you include more detail? For example, the whole output generated from that command? (I don’t have a Win 32 bit system, so there is no way for me to go find out for myself.)

In general: Please read: make it easier to help you

There was a problem with the Package GtkObservables, I remover ImageView and added GtkObservables first and then add ImageView this reduced the errors to 1 ? for the package Libffi_jll. I tried the same trick but without success

I’m really bad at mind-reading. There’s nothing better than a full copy/paste of all the things you tried and what the error messages were :slight_smile:.


_ _ ()_ | Documentation:
() | () () |
_ _ | | __ _ | Type “?” for help, “]?” for Pkg help.
| | | | | | |/ ` | |
| | |
| | | | (
| | | Version 1.9.0-rc1 (2023-03-07)
/ |_|||_’_| | Official release
|__/ |

(@v1.9) pkg> up
Updating registry at C:\Users\GregE\.julia\registries\General.toml
No Changes to C:\Users\GregE\.julia\environments\v1.9\Project.toml
No Changes to C:\Users\GregE\.julia\environments\v1.9\Manifest.toml

(@v1.9) pkg> st
Status C:\Users\GregE\.julia\environments\v1.9\Project.toml
[8710efd8] GtkObservables v1.2.7
[82e4d734] ImageIO v0.6.6
[86fae568] ImageView v0.11.4
? [e9f186c6] Libffi_jll v3.2.2+1
Info Packages marked with ? have new versions available but compatibility constr
aints restrict them from upgrading. To see why use status --outdated

(@v1.9) pkg>

Sorry Have remember my dos tools

Info Packages marked with ? have new versions available but compatibility constr
aints restrict them from upgrading. To see why use status --outdated

(@v1.9) pkg> status --outdated
Status C:\Users\GregE\.julia\environments\v1.9\Project.toml
? [e9f186c6] Libffi_jll v3.2.2+1 (<v3.4.4+0): Glib_jll, HarfBuzz_jll, Wayland_jl

(@v1.9) pkg>

Did you read the link that Tim posted above, in particular

Post quoted code by enclosing code blocks in triple-backticks ```:

yes I have read the link from Tim.
There is no code in the questions, only installation problems.
I have not achieved the ability to use Julia for anything so far.
Data is still the missing element.

But you did copy some code in your previous messages. It’d be much easier to read for people willing to help you if you followed the suggestion to quote your code with the triple quotes, or select the code in the input area when editing the message and press the </> button to automatically quote it.

Tim asked you to show what error message you got, you haven’t showed it. It’s hard to help you if no one knows what’s exactly the problem you’re facing.

There are people who would like to help you out here, but if you don’t make it easy for them to help you, this is probably not going anywhere.

Thank for taking time to explain, I will wait until a more advanced release.

FYI: You can use 32-bit Julia on 64-bit Windows (I assume, I at least tried such on Linux).

EDIT: I see this hint was helpful, for testing as I intended, not really for normal use (for Windows, it should run all 32-bit apps, just as if they had been run on 32-bit Windows. Ideally on Linux running 32-bit should work in all cases but I now recall problems, maybe it was only when using with PyCall, likely the 32-bit app trying to link with 64-bit app/libpython, might also apply on Windows?).

Thank you!

Big investment to move from 32bit to 64bit for Julia

Just to clarify, the following message is NOT an error and does not indicate failure.

Info Packages marked with ? have new versions available but compatibility constr
aints restrict them from upgrading

A new version of Libffi_jll is available but this is not known to be compatible with the other versions of the packages you have selected. This was done intentionally to make sure that packages work well together. There is nothing wrong with Libffi_jll. It is intentionally at version 3.2.2. Your Julia install seems to be working perfectly as intended.

@g4734e, @Palli’s comment was directed at me (as a way to try to reproduce the failure on my own machine), not you.

There seems to be some miscommunication here, so let’s start with the basics. In Julia, errors are usually printed starting with “ERROR,” typically in red font. As @mkitti said, none of what you posted is an error. Here’s an example of an error (one I’m triggering deliberately with bad input) on a different function:

julia> sqrt(-1)
ERROR: DomainError with -1.0:
sqrt will only return a complex result if called with a complex argument. Try sqrt(Complex(x)).
 [1] throw_complex_domainerror(f::Symbol, x::Float64)
   @ Base.Math ./math.jl:33
 [2] sqrt
   @ ./math.jl:677 [inlined]
 [3] sqrt(x::Int64)
   @ Base.Math ./math.jl:1491
 [4] top-level scope
   @ REPL[1]:1

You can see that “ERROR” printed, which indeed is red on my machine. After the description of the cause, the list of lines that follows (starting with “[1]”) is called the “stacktrace.”

We’ve all been hoping you’d post the same kind of output for what happens when you type Pkg.add("ImageView"). Or, if that doesn’t produce anything with “ERROR” in it, what does julia> using ImageView produce? One of those should be an ERROR.

But @Palli’s comment prompted me to remember that I can test 32-bit windows on GitHub. I went ahead and did this, and exactly as you report, there was an error. It has now been fixed, so you might want to try again:

julia> using Pkg

julia> Pkg.update()

julia> using ImageView

If that doesn’t work, please post what happens.