What am I doing wrong, I can't use Julia with jupyterlab?

Hello, yesterday I was able to use julia with jupyterlab simply. I just followed the instructions. But when I turned on my PC, next morning it didn’t work. I tried reinstalling julia, and IJulia. But it didn’t work. Please help!

It’s impossible to help if you don’t give any concrete information (see Please read: make it easier to help you). Without that I don’t think anyone can help you other than suggesting you to “try turning it off and on again”.

What does for example “didn’t work” mean? What was the error? Any output at all?

1 Like

It said 404 GET /api/kernels/5e04c192-38ea-4a12-bdf1-e3a9cd1fa90a/channels?session_id=a60a0b60-4dcc-4412-b744-f9cd3cbe5cb1 (::1): Kernel does not exist: 5e04c192-38ea-4a12-bdf1-e3a9cd1fa90a [W 08:59:59.458 LabApp] 404 GET /api/kernels/5e04c192-38ea-4a12-bdf1-e3a9cd1fa90a/channels?session_id=a60a0b60-4dcc-4412-b744-f9cd3cbe5cb1 (::1) 7.00ms referer=None [I 09:00:06.886 LabApp] Kernel started: aa03bedf-d22e-442b-a8ac-db52e964738f, name: julia-1.6 [W 09:00:13.607 LabApp] 404 GET /lsp/kite_installed?1624950013599 (::1) 2.00ms referer=http://localhost:8888/lab/workspaces/auto-s Starting kernel event loops. [W 09:01:06.924 LabApp] Timeout waiting for kernel_info reply from aa03bedf-d22e-442b-a8ac-db52e964738f
That is the error it gave. I think it means that it just can’t connect with Julia.

It is alright now it works.