Having problem with Convex.jl

I’m new to Julia. While I was going through the Julia for Data Science course’s ** Numerical Optimization** lecture, got stucked in solve!() unfortunately. Explored in different forums but could not get the solution regarding SCS.Optimizer

After executing:
solve!(problem, SCS.Optimizer)

I’m getting:
MethodError: no method matching solve!(::Problem, ::Type{SCS.Optimizer})

Updated Convex to 0.14.5 but still doesn’t work. Besides, from Convex’s github page, tried the given examples regardins solve!() function, but not luck with non-error output.

I’m from a non-CS background, so you could say me a boomer to programming indeed. Not sure where is the problem, followed the given codes from the course’s .ipynb, still doesn’t work in ma machine.

NB: using
Win10 64bit (Home) OS
Julia 1.7.2 on Jupyter notebook


The error message in the screenshot makes it look like you have a very old version of Convex.jl; that references MathProgBase which we stopped using in Convex a few years ago.

How did you update? Try

using Pkg
Pkg.add(PackageSpec(name="Convex", version=v"0.14.5"))

If you get an error, copy the whole message here.

Also, please read this post: Please read: make it easier to help you.


This often catches people out: when you update your packages, you need to restart Julia for the change to take effect.


Tnaks a lot for the solution. I updated the Convex.jl likewise but restarting the REPL was the thing that didn’t do. And ya, the attached linked was helpful and will follow afterwards. Thanks for the support!


Ya! It’s working now! Thanks a lot for helping out. Form now, it is a to go task for me, if something goes wrong, restart the REPL or notebook! Thank you for your support.