Problem with SPICE package installation

So i was trying to install the SPICE package by julia Astro and i used the command
Pkg.clone(“GitHub - JuliaAstro/SPICE.jl: Julia wrapper for NASA NAIF's SPICE toolkit”)

but i cannot use the package

I get the error
Package SPICE [c2290294-eb73-5b2e-bb90-69dd5239354b] is required but does not seem to be installed:
** - Run Pkg.instantiate() to install all recorded dependencies.**

even though when i run Pkg.installed() it shows the package SPICE

please help me!!

You shouldn’t really be using Pkg.installed(), use Pkg.status() instead.

What is the output of Pkg.status()?

PS. Copy and paste the input/output from the terminal instead of using print screen, since images can be difficult to read, and they are not searchable.

1 Like

This is the output of Pkg.status()

As @fredrikekre points out, follow this guide when asking for help: Please read: make it easier to help you. I think you will find volunteers are more willing to help when you show initiative in finding a solution.

1 Like

So, what is the content of ~/.julia/dev/SPICE? What if you Pkg.rm("SPICE") and then add it again with Pkg.add instead of Pkg.clone?

And again:

@fredrikekre when I do Pkg.add(“SPICE”) I get the error
ERROR: The following package names could not be resolved:
** * SPICE (not found in project, manifest or registry)**
Please specify by known name=uuid.

SPICE is not registered so you need to add with a url:

Pkg.add(PackageSpec(url = ""))
1 Like

thanks a ton man!!!

It has been two days since I am trying to install SPICE.jl but got no luck.
I have tried it on Julia 1.0
I am getting the error

ERROR: Unsatisfiable requirements detected for package Requests [df88083b]:
** Requests [df88083b] log:**
** ├─possible versions are: [0.0.1-0.0.8, 0.1.0-0.1.1, 0.2.0-0.2.4, 0.3.0-0.3.13, 0.4.0-0.4.1, 0.5.0-0.5.1] or uninstalled**
** ├─restricted to versions 0.0.0-* by SPICE [c2290294], leaving only versions [0.0.1-0.0.8, 0.1.0-0.1.1, 0.2.0-0.2.4, 0.3.0-0.3.13, 0.4.0-0.4.1, 0.5.0-0.5.1]**
** │ └─SPICE [c2290294] log:**
** │ ├─possible versions are: 0.0.0 or uninstalled**
** │ └─SPICE [c2290294] is fixed to version 0.0.0**
** └─restricted by julia compatibility requirements to versions: uninstalled — no versions left**

can anyone please help

SPICE doesn’t seem to be a registered package. How are you getting it? This error message makes it look like you are using a fixed 0.0.0 version of SPICE.

1 Like

Please don’t open a duplicate thread of your own; Problem with SPICE package installation.