[ANN] Juno 0.6.7

announcement
juno

#101

Thanks @pfitzseb

  • Use Standard Layout - yes, it was enabled. I disabled it but still, it doesn’t help much. Now all the tabs are gobbled into the main view (the side panel is removed on restart)
  • My Atom.jl is at version 0.6.6 :blush: But it does not get updated. I need to mention that this install was originally a JuliaPro configuration – but I unpinned the JuliaPro packages and updated them and Atom. So presumably some other Julia package is holding Atom.jl back?

Maybe the JuliaPro legacy messes things up somehow. I’ll try with a clean install. Although I preferred having the Julia IDE separated from my default Atom which I use for other languages.


#102

You could also try using the latest JuliaPro release, which should work fine :slight_smile:


#103

Ah, great, I’ll update JuliaPro, thanks :slight_smile:


#104

I had the same layout problem, with Atom 0.6.10.
The “Use Standard Layout” option is not there, but the issue was fixed by disabling the “First Boot” option. Presumably, according to that option’s name, it was supposed to be disabled automatically somehow after the first boot?


#105

Yeah. Turns out I forgot to tag a new release after fixing that bug… my bad. The layout troubles should definitely be fixed with julia-client 0.6.10 (and Atom.jl 0.6.11), but be sure to check your settings if you’re upgrading from an old install – there’s been a few changes there.


#106

After updating to the latest version of Julia Client / Ink, Atom has become unresponsive. That is, the menus still work, but the editing window is unresponsive and just ‘gray’:

I cannot open any documents, preferences or anything. Restarting Atom makes no difference.

I cannot say for sure if Julia Client has anything to do with it – I seem to remember that one more extension was updated at the same time.

Any ideas?


#107

Looks weird. Try starting Atom with atom --clear-window-state from a terminal.


#108

Great, that worked. Thanks.


#109

Haven’t used Juno for a little while and just updated all packages (including juno) today. All of sudden, it hangs when run any code with shift+enter in the editor. REPL works as normal. Restarted a few times but no change. Any clue?


#110

I hit that same problem and resolved it by updating the Julia client within Atom.


#111

Thanks! Yes, it works. But all the buttons are gone. How can I restore all the click-able buttons in the bar on the left of the editor panes?


#112

See Juno toolbar not showing on my Windows 10 setup


#113

Thanks for the pointer!


#114

The old bug surges back - after finishing debugging, the REPL still lives in debugger mode, instead of returning to Julia.

Btw, what is the command to manually exit the debugging mode in the REPL?

Thanks!!


#115

Are you on the latest version of Atom.jl?
Also, did you start debugging in the REPL or in an editor?


#116

Sorry. I’m using JuliaPro and all packages are up to date, including Atom.jl, I guess. This is what Pkg.installed() returns me:

"Atom"=>v"0.6.11" 

I’m debugging in the editor of Juno by adding @enter in front of the line to debug and running by shift+enter. Am I missing anything?


#117

No, I think that’s a bug. Should only be cosmetic though, at least if the prompt is green instead of purple after you finished debugging.


#118

Yes, it’s green.

What I did is to start debugging by stepping into a function first and once inside the function immediately click the first debugging button, i.e. finishing this function. I expected the debugging would cease and the REPL returns to Juliia. But it hangs with the green debug prompt and the only way I know to bail out is to click the square button for stop Julia.


#119

Ok, weird. If I do that then I have a green debug> prompt but the REPL works fine afterwards:

debug>
debug> 1+1
2

#120

I can’t reproduce the hanging. But shouldn’t the prompt be returned to Julia after debugging?