Juno toolbar not showing on my Windows 10 setup

juno

#1

I have installed Atom and installed the package “julia-client 0.6.10” on my Windows 10 machine. In the UI Options I checked Enable toolbar and in the console options I checked “First Boot” and “Enable Tool Bar” then I restarted Atom.

The tool bar still didn’t appear. Is this a known bug? I checked this issue https://github.com/JunoLab/atom-julia-client/issues/435 and I have done “Enable menu and enable tool bar” but the tool bar still doesn’t appear.


[ANN] Juno 0.6.7
#2

Did you try the Tool Bar: Toggle command as well?


#3

I can confirm this behavior and Toggle Bar: Toggle does not help. I even tried to uninstall every package and reinstall uber-juno.

I am currently doing OK since I can access everything on the toolbar by ctrl-shift-p and I actually kind of hate the lookings of toolbar. So maybe it’s a chance for me to get rid of it.


#4

It occurred a couple days ago when I was updating julia-client and ink behind my company’s proxy(the internet was laggy, the update failed several times, which I thought was the problem, but maybe not). I finally fixed it by completely uninstalling Atom and reinstalling uber-juno: https://discuss.atom.io/t/how-to-completely-uninstall-atom-from-windows/17338. Caveat: you will lose all of Atom settings, don’t forget to backup before you delete these folders.


#5

Maybe you can experiment with your atom config files to try to retain the settings that don’t affect the issue


#6

I tried the complete uninstall method but it is still having the same issues.


#7

Hi
I had to run the command Tool Bar: Toggle in the command pallet Ctrl + Shift + P.

J


#8

You may open “Julia Client: Settings”, goto “UI Options”, and check “Enable Toolbar”.


#10

I had this issue as well. Ctrl + Alt + T wasn’t doing it, but there was a nearly imperceptible jitter on the left hand side every time I hit that key combination, and “Julia Client” didn’t have a settings button. Uninstalling and reinstalling julia-client fixed it for me.