[ANN] Juno 0.7

announcement
juno

#1

Hey folks,

Juno 0.7 is out! There’s a plethora of bugfixes, improvements, and new features:

  • Workspace Pane allows filtering
  • Plot Pane UI improved
  • Terminal
    • better default colors, especially on light backgrounds
    • fallback renderer for those who see performance issues in the REPL
    • selectable cursor styles
  • the Profile Pane supports loading and saving profile traces
  • and more…

Bugs are best reported here and we’ll do our best to answer any and all questions you might have in the Gitter chat, Slack or here on Discourse.

Installation

This version of Juno supports Julia 0.6 and has preliminary support for Julia 0.7-beta2 and up.

Important: Restart Atom before updating julia-client or ink and do not start a Julia session.
If that does not work, close all Atom instances and type

apm install ink
apm install julia-client

into a terminal.

Julia 0.6:

  • Atom.jl v0.6.15
  • Juno.jl v0.4.1
  • CodeTools.jl v0.5.0 or 0.5.1

Julia 0.7-beta2:

pkg> add Atom should be enough to get you up to speed now.

For Package Developers

Juno on Julia 0.7 will have a couple of very breaking changes, most importantly regarding plots, progress bars, and tree views. The documentation isn’t quite updated yet, but you can find some info about Juno on Julia 0.7 here. I hope I’ll have something more formal in the docs in the next couple of days.

If you have any questions regarding the new APIs or whatever, feel free to reach out to me.


#2

This is great, especially happy to hear about support for the show plot support!


#3

I think the progress meter changes on v0.7 are fantastic. Now to get cross IDE + REPL support for the same progress API, we really just need to solve this:


#4

Here’s DiffEq looking full v0.7 with the new TreeViews and progress meter integration:

Awesome stuff @pfitzseb !


#5

Hello!

I just updated 3 packages today. (can’t remember exactly what they were, i just clicked update all. But i think it was “ink” and some other 2). But after the update, the Julia Command Prompt in Atom Terminal Window is gone. I can’t run my codes anymore.


#6

I had the same experience; I then uninstalled julia-client from Atom and typed in apm install julia-client from a command prompt as mentioned in the notes above and now it works nicely!


#7

I uninstalled the julia-client in Atom. Opened the Julia command prompt and typed apm install julia-client, but i’m getting this error:

ERROR: syntax: extra token “install” after end of expression

EDIT: I tried install the Julia-Client through Atom (going to File>Settings>Install), and it worked, the Julia Command Prompt is back there. But i got this warning.

WARNING: Atom.jl: unrecognised message enableplotpane.

A graphic i’m trying to plot isn’t appearing in the Plot Tab.


#8

Don’t type it into the Julia prompt, just in a normal terminal session (cmd on Windows, e.g. bash on Unixes).


#9

WARNING: Atom.jl: unrecognised message enableplotpane.

That sounds like you’re on an old version of Atom.jl, so please Pkg.update().


#10

I’m trying to use Juno with Julia v0.7.0-beta2 but it does not seem to retain my setting when I set the julia-path setting in Julia Client and always comes back to Julia v0.6.4. I’m sure I’ve forgotten something completely obvious but don’t know what it is. This is on Windows 8.


#11

Did you specify an absolute path to the Julia 0.7 binary?


#12

Yes I did.


#13

So does the path setting itself change or are you just getting the wrong julia version?


#14

I set julia-path in the julia-client settings to C:\Julia-0.7.0-beta2\bin\julia.exe

When I exit and restart Juno, it has reverted back to C:\Julia-0.6.4\bin\julia.exe

I have not changed the system path environmental variable so it may still point to v0.6.4. I use both JULIA_HOME and JULIA_BINDIR environment variables so I can use either v0.6.4 and v0.7.0 as needed.


#15

Do you have multiple instances of Atom open at the same time? If so, please close them all, open one new window and try again.
If that doesn’t work then go to C:\Users\YourUserName\.atom\config.cson and change the "juliaPath" setting to C:\Julia-0.7.0-beta2\bin\julia.exe.


#16

Only one instance open so that’s not it.

I’ll change the entry in the .cson file. I thought there was something like that but didn’t know where it was.

Thanks for your very prompt help.


#17

After changing the JuliaPath entry in the config.cson file and doing add Juno in pkg3, Juno is now working for Julia v0.7.0-beta2. Thanks again for your help.


#18

Two quick announcements:

  1. Juno now works on Julia 1.0.
  2. We have a new website (which hopefully shows of more of the features Juno offers): http://junolab.org/

You’ll need to have

  • julia-client on version 0.7.3
  • ink on version 0.9.4

installed on the Atom side and

  • Atom.jl version 0.7.3
  • Juno.jl version 0.5.2

installed in Julia.

When updating, then call pkg> update in Julia and apm update in a terminal to update the Atom packages.

If you’re installing Juno for the first time, then just follow the installation instructions.


cant start julia in juno
#19

Does the debugging experience shown on the website work on Julia 1.0.0?
If not, could you state what is working and what is not working with Julia 1.0.0?

Thank You.


#20

I have to install uber-juno after julia-client and ink in order to make it to work properly. I don’t understand why this is the case.