[ANN] Juno 0.6.7

announcement
juno

#121

Sure, that’s why I said it’s a bug :slight_smile:


#122

Cool. Can it be easily fixed? Hope to have this fixed soon.


#123

Btw, is it possible to have the hotkeys, e.g. F10 and F11, enabled even the cursor is at the REPL? It’s cumbersome and time-consuming to manually click the editor using the mouse or the touchpad to be able to use the hotkeys.


#124

Cool. Can it be easily fixed? Hope to have this fixed soon.

Fixed on Atom.jl master.

Btw, is it possible to have the hotkeys, e.g. F10 and F11, enabled even the cursor is at the REPL? It’s cumbersome and time-consuming to manually click the editor using the mouse or the touchpad to be able to use the hotkeys.

Yes, but it’s not super easy. Please open an issue about this at the Juno.jl repo.


#125

Thanks, buddy! Ticket filed and thanks for the fix!!!

Btw, enjoyed using the toggle that I requested. Really appreciate! Thanks!!


#126

Another question - The first suggestion given by the auto-completion in the drop-down list is usually the desired one. However, firing the Enter key doesn’t pick the first choice, but break the current line. I have to use each of the down and up keys once before Enter works for selecting the first suggestion. Any comments?


#127

You can change this in the autocomplete-plus settings to whatever you want:


#128

Where can I find the toggle?


#129

Go to Settings > Packages > autocomplete-plus and scoll down a bit.


#130

Cool. Thanks!


#131

Juno 0.6.12 is out!

Many of the bugs mentioned above should be fixed this release.

New features:

  • Documentation (accessible with C-J C-D or right click and Show Documentation) is now displayed in the Documentation Pane by default. There is a setting for this if you’d rather have the old behaviour of showing it inline back.
  • When opening a new (non-julia) terminal you have the option of specifying the working directory (either select it from a list of the currently open projects or type in an arbitrary path).
  • The plot pane supports multiple plots now (only for non-interactive backends though).

#132

I’m on linux mint and I was still getting these messages after upgrading via Pkg.update(). I got it to work by using Pkg.checkout(“Atom”), and Pkg.checkout(“Juno”) which was used to solve this problem:

I have a feeling though that this is certainly the wrong approach. I currently am using atom 1.26.1, which was the latest as of this post and do have julia 0.6.2.


#133

Sorry if I’m abusing this thread by asking questions not immediately relevant.

  1. Is it true that @ASTInterpreter2 is now built-in or bundled with something which is built-in? I noticed that I don’t have to type using ASTInterpreter2 in the REPL these days to have the debugger ready to use.

  2. How to change the background of the REPL to a light color? I know how to change the background color for most of the UI windows in Juno - just change the ‘theme’. But the REPL’s dark background color seems immutable at all.

  1. Just noted that the cute bug sign (indicating where the debugger travels to) is missing after converting to light-color background. Is this a bug?

Thanks!


#134

Sorry if I’m abusing this thread by asking questions not immediately relevant.

That’s perfectly fine :slight_smile:

Is it true that @ASTInterpreter2 is now built-in or bundled with something which is built-in? I noticed that I don’t have to type using ASTInterpreter2 in the REPL these days to have the debugger ready to use.

Yeah, Juno directly depends on ASTInterpreter2 (always has).

How to change the background of the REPL to a light color? I know how to change the background color for most of the UI windows in Juno - just change the ‘theme’. But the REPL’s dark background color seems immutable at all.

Just restart Atom after changing the theme. We might be able to work around that but I couldn’t be bothered with implementing anything like that yet.

Just noted that the cute bug sign (indicating where the debugger travels to) is missing after converting to light-color background. Is this a bug?

I can’t reproduce this with the One Light theme, so this either got fixed since the last release or there’s something wrong on your end.


#135

Haven’t updated Juno.jl and other packages for a little while. I guess I still had to explicitly call ASTInterpreter2 in the REPL back in February. Anyhow, thanks for confirming.

You’re absolutely right. I have to restart Atom to reflect the change. After restarting, the REPL color is consistent and the bug sign appears as expected when debugging. So it’s not a bug at all. My apology!!

Thanks, buddy.