Problem in upgrading Atom to Julia 1.4

I have upgraded to Julia 1.4. On terminal, Julia runs smoothly but on Atom, the packages do not load. If I run using Pkg, for instance, the evaluator remains stuck.
What might be the problem?

Also, I tried to copy only the executive in /bin/julia into the directory I have made for Julia, following this post; but the version remained the old one. Is this truly the best way of upgrading Julia? or do I need to copy also all the other files given in the tar.gz file?

  1. Check ~/.julia/config/juno_startup.jl. You might just want to rename the file so it’s not executed. You probably should do the same for ~/.julia/config/startup.jl if that exists as well.
  2. Can you just run julia in a terminal or is that stuck too?
  3. When it’s “stuck” how much CPU usage are you seeing and what processes are using it? i.e Do you see Julia using a full core? Or maybe Atom?
  4. How/where is julia installed? How/where was the old version julia installed? Did you uninstall the old version? Rename it? Remove it?
  5. If you installed the new version somewhere custom did you modify .bashrc or another file to include julia/bin in the path?
  6. Did you configure Atom to load julia from a specific directory or leave all that blank and just allow it load from the system?
  7. Did check your Atom packages for updates and apply those updates?

Those are my big questions for the moment that might help figure out what is going on…

Thank for your anzwer:

  1. there is no start up:
$ cat ~/.julia/config/juno_startup.jl
cat: /home/gigiux/.julia/config/juno_startup.jl: No such file or directory
$ cat ~/.julia/config/startup.jl
cat: /home/gigiux/.julia/config/startup.jl: No such file or directory

2 Julia runs on terminal all right as
Version 1.4.1 (2020-04-14)
3 I have a basal use of 3.1 GiB, when starting Julia from Atom I now get this error (which was not there last time I launched):

julia> ┌ Warning: Juno's evalrepl handler is deprecated.
└ @ Atom ~/.julia/packages/Atom/wlPiw/src/eval.jl:133
┌ Warning: Atom.jl: unrecognised message `cacheCompletions`.
│ Please make sure your Atom and Julia packages are in sync.
│   - Try `using Pkg; Pkg.update()` to update this package.
│   - Check for `julia-client` updates in Atom.
└ @ Atom ~/.julia/packages/Atom/wlPiw/src/comm.jl:175

and the consumption goes only to 3.5 GiB, but julai is stuck.
4. I have a folder ~/Julia I simply deleted all the subfolder and copied the new ones there. I then have a symbolic link to ~/Julia/bin/julia.
5. since I got the link, I did not modify .vashrc. And it was working until the upgrade.
6. I simply gave the location of the julia executive
7. I only used Pkg.update(): Atom does not show any update need and it was working perfectly until the upgrade.

More in general, I am experiencing these sort of issues every time I upgrade. I tried from the terminal with apt-get but I got installed an older version. Is there an easier and safer way to upgrade Julia?

Seems like your Atom and Julia packages aren’t in sync, as the warning suggests. Did you try updating julia-client and ink to the latest version?
The fact that you don’t see any suggested updates might indicate that you’re on a very old Atom version. Take a look at the requirements listed at

The warnings you are now getting definitely make it sound like something is out of sync.

My julia-client package in Atom is 0.12.4. Clicking on the name goes to https://atom.io/packages/julia-client which says 0.12.4 is the latest version. I would check that on your system.

Inside julia running:

using Pkg
Pkg.status()

Reports the atom package in Julia is at:

[c52e3926] Atom v0.12.10

Which appears to be the latest as well. I assume once you get both those upgraded things should work.

As for upgrades I have a “bin” directory under home. I tend to just extract the Julia archive under there so I end up with a “julia-1.4.0”, “julia-1.4.1”, etc directory. Then in my .bashrc file I update the PATH environment variable to add the julia-1.4.1/bin directory to my path.

I haven’t had any problems with that model, and if I have an issue with the latest version of Julia I can update the path to point back to the older version if I want. I had been using my distro’s version before that but they where having issues packaging it correctly so I switch to this, which is working fine.

1 Like

Helo, I also have the latest version:

[c52e3926] Atom v0.12.10

I got, however, some packages that were not updated. I tried package rebuild in Atom and I got:
Screenshot from 2020-05-04 23-41-46

I re-installed Atom and uber-juno but I got catastrophic sync: julia-client does not run (even if I reinstalled even that) and I can’t open juno settings. Essentially, I don’t have Julia on tom any more, the opposite of upgrading. I got these error flags:
Screenshot from 2020-05-05 22-49-45
I tried the solution using Atom given here but obviously it did not work.
Any tips?

Try this.

2 Likes

Looks like it worked! Thank you