Juno error: Error loading Atom.jl package

juno

#1

When I selected a few lines of code and then selected Julia -> Run Block, I get the following error message: “Go to the Packages → Julia → Open Terminal menu and
run Pkg.update()in Julia, then try again.
If you still see an issue, please report it to…”

The first time I followed these instructions, I got error messages about not having accepted the xcode license (I’m using macBook Pro), with instructions to run
"sudo xcodebuild -license".
I ran this in a separate terminal window, and typed ‘agree’ when it asked me to. But I still can’t run a block of code as described at the beginning. When I try, I still get the error suggesting to run Pkg.update(). However, now when I run that command, it says “INFO: No packages to install, update or remove”.

Any suggestions?


#2

Did you try::

using Atom

in a terminal window?


#3

When I try typing “using Atom” in a Julia terminal window, I get the following warnings and errors:

julia> using Atom
INFO: Precompiling module Atom...
WARNING: New definition 
    all(Any, Lazy.List) at 
ERROR: LoadError: LoadError: Unable to load 

lib (/Users/machine-name/.julia/v0.4/HttpParser/deps/usr/lib/libhttp_parser.dylib)

Please re-run Pkg.build(package), and restart Julia.
 in include at /Applications/Julia-0.4.5.app/Contents/Resources/julia/lib/julia/sys.dylib
 in include_from_node1 at /Applications/Julia-0.4.5.app/Contents/Resources/julia/lib/julia/sys.dylib
 in include at /Applications/Julia-0.4.5.app/Contents/Resources/julia/lib/julia/sys.dylib
 in include_from_node1 at /Applications/Julia-0.4.5.app/Contents/Resources/julia/lib/julia/sys.dylib
 [inlined code] from none:2
 in anonymous at no file:0
 in process_options at /Applications/Julia-0.4.5.app/Contents/Resources/julia/lib/julia/sys.dylib
 in _start at /Applications/Julia-0.4.5.app/Contents/Resources/julia/lib/julia/sys.dylib
while loading ....

#4

Looks like you have Julia 0.4 installed. I would try to upgrade to 0.5 or 0.5.1 .


#5

I’ve downloaded and installed JuliaPro, but when I type Julia at a terminal
prompt, or Run Block as described in my first message, it is still using
version 0.4 rather than 0.5. What am I doing wrong?


#6

Try to delete version 0.4. How did you install it?


#7

Deleting it might cause things to break even further. More likely you need to find the right setting in Juno to tell it to use your 0.5 rather than 0.4. Or adjust your paths so 0.5 comes earlier.


#8

Thanks for the tip! I changed the version of Julia pointed to by the result of which julia in a terminal, and also in Atom -> Settings -> Julia-client -> Julia path, and now things are working. Hooray!