Julia doesn't start in Juno (Atom)

error

#1

Hi everybody,

I just installed Julia and Atom with Juno on my new virtual machine and it doesn’t work. I simply cannot start Julia from Juno. REPL shows the following message:

Starting Julia…
ERROR: unknown option -3

Julia has exited. Press Enter to start a new session.

I had used Juno before on the same configuration (Win10 + Oracle Virtualbox + Ubuntu1604) and it worked. I thing I did everything correct with the installation. Julia works fine from Terminal.

Regards,
Jakub


#2

It seems that I updated everything except from Julia itself. It works now! I will leave the topic in case anyone else has this issue.


#3

Hello @jakub i am having the same error currently,my juno works fine with the new 0.6.3 version but i need to use 0.4.7 or previous versions,when i try to execute julia using it’s executable path in REPL i get this error.Please note that the 0.4.7 version does work independently just not in REPL.
PS:Complete beginner here any help will be greatly appreciated


#4

Hi @Ishan1997. I just reinstalled and updated everything and it works now. But this obviously won’t work in your case if you wanna use older version. Maybe try using jupyter notebook instead? It works with fine with Julia. There are planty of guides on the Internet on how to install and use it.


#5

You could try

apm install julia-client@0.4.7
apm install ink@0.4.4

but I’m not sure if those package versions even work with a current Atom anymore.


#6

Thanks @pfitzseb and @jakub for replying.After posting that reply i did quite a lot of digging around and found out that it is juno’s fault for loading julia with -o flag.This works only for the newer julia versions it seems(0.6+),after seeing a github issue i found the line to boot julia in “client.coffee” file of juno’s installation,after modifying it unfortunately much more errors spawned in Boot.jl.
Somehow i did manage to install ijulia (0.6.3) in jupyter but it won’trecognize the .jl files,opens them as plaintext and sometimes unable to see them.

Actually I am just an intern who has been assigned to fix this 3 year old julia project but there are much errors regarding versions.Mostly ODBC doesnt work and i might have to change syntax for deprecated requires statements and many macros if i choose to port to 0.6.3.
However syntax is fine in 0.4.7 but the version seems deprecated and i am unable to use atom for running older versions of julia.
Is there a workaround to use these old julia versions easily.
Thanks again for the reply.


#7

You could just use the REPL for running your files until you’ve updated them for more recent versions of Julia.

Juno only supports the latest released version of Julia by default, so if you want something else you’ll have to try your hand at older versions of packages etc.


#8

Yup been doing that for now and trying to do some things with Pkg.checkout for various packages.Thanks :slight_smile: