Julia-client / juno problems after update to 0.6.10

juno

#1

I’m running in to some problems that seem to be associated with the Atom package julia-client that (as far as I understand) provides most of the functionality of Juno. After updating julia-client to v0.6.10 and restarting Atom, the Juno toolbar and Juno REPL were both missing, and the Packages > Julia menu is gone.

I have tried toggling the toolbar from the command palette, to no effect. Commands like Julia: Standard Layout are gone from the command palette (in fact, searching for “julia” in the command palette now only brings up Language Julia: Toggle Docstrings and :Toggle All Docstrings). I have tried uninstalling and reinstalling the packages, as well as

There are no visible error messages associated with any of this that I could find to report, but this is with versions:

Atom: 1.25.0
julia-client: 0.6.10
uber-juno: 0.1.2
ink: 0.8.3
tool-bar: 1.1.6
language-julia: 0.15.0
julia: 0.6.2 (no problems here from the command line)

on Mac OS X v10.11.6

Is anyone else having similar issues?


#3

Command+Shift+P -> Tool Bar: Toggle


#4

I tried that, but nothing happens


#5

This might be a long shot, but have you enabled the Julia Menu and Toolbar in package settings?

File -> Settings -> Packages -> julia-client -> Settings

Then under UI Options, make sure these are ticked:

  • Enable Menu
  • Enable Toolbar

#6

Looks nominal. I tried un-checking and re-checking these just to be sure.


#7

Those are the wrong ones – you’ll need to toggle the one under the UI Options heading.


#8

No such heading? All I have under Settings -> Packages -> julia-client is “Settings” and “Keybindings”


#9

To document a bit more of the context I mentioned in the initial post, even though I have all of the juno-lab addons enabled, only the julia-language commands appear when searching the command palette and Packages -> Julia is gone. This was not the case prior to updating julia-client to 0.6.10.


#10

Right. You should have a little red bug symbol in the status bar. If you click on it and then use the Rebuild Native Dependencies button (or something similar) you should be good to go. I’ll add something to our FAQ tomorrow.


#11

That seems to have fixed it, thanks!