Julia doesn't start in Atom(juno)

Hello everyone,

I was programming in Julia then the Atom stopped work.
I installed Julia and Atom with Juno on my machine (Windows 10) and it doesn’t work. I simply cannot start Julia from Juno. REPL shows the following message: “Press Enter to start Julia”, but nothing happens.
I’ve already done cleanly uninstall and reinstalled, but, it doesn’t work. Julia works fine from Terminal.

1 Like

My only thought is that the path in the settings may not be correct. Make sure it points to a working Julia installation.

I have the same issue (“Press Enter to start Julia” does nothing). I’ve performed the install of JuliaPro (today) on two different Windows 10 PC’s with the same results.

One answer is “Make sure it points to a working Julia installation”. But what is “it”?

When you go to Packages/Julia in Atom, there’s an option for “Settings” right at the end. Clicking on that opens a window in Atom with several settings, and one of them if a path to the Julia binary. I don’t know where the binary is store in Windows, but you can see what the current path is and then navigate to that location with with the command line or the file manager, and test if the Julia binary is indeed located there. If not, you can find it and rewrite the path on Atom.

Might be a problem with your Antivir software:

1 Like

Thanks for the quick response. But I have checked that. I have even copy-and-pasted in the the path (i.e., removing any typos from my fingers) and still the same non-results. Julia does start up when I click on that path.

And that path is exactly the one suggested in the installation (again, without me typing anything in). I have even uninstalled and installed on a folder on my desktop. Still the same results.

Now from one of the threads I did change the Console Options from “REPL-based” to “Legacy” and then things work. But that still doesn’t explain why the initial issue occurs.

Also, although Julia works after changing to “Legacy”, with the first command given I get a “Julia Client - Internal Error”: UndefVarError: active_repl not defined. That would seem to be related to changing from “REPL-based” to “Legacy”.

It could be associated with Antivirus software. One would need more specifics to explore that possibility.

This might be helpful too.

I had a similar issue, Nothing would show up in the terminal when I update any packages in Atom. I have to uninstall atom, and manually all its hidden folders in APPDATA, then reinstall everything.

I certainly have a lot to learn about Julia. The link you provided about the one particular exemption for the MacAfee virus application did the trick.

Thank you!

Glad it’s working for you now!

I have the same problem but don’t have McAfee installed.
Atom had been crashing sporadically prior to this issue, but now it refuses to even open Julia with the issue described above.

Running on a Windows 10, Juno Debug info below:


Version: 1.47.0
Dev Mode: false
Official Release: true
“node”: “12.0.0”,
“v8”: “7.3.492.27-electron.0”,
“uv”: “1.27.0”,
“zlib”: “1.2.11”,
“brotli”: “1.0.7”,
“ares”: “1.15.0”,
“modules”: “70”,
“nghttp2”: “1.34.0”,
“napi”: “4”,
“llhttp”: “1.1.1”,
“http_parser”: “2.8.0”,
“openssl”: “1.1.0”,
“icu”: “63.1”,
“unicode”: “11.0”,
“electron”: “5.0.13”,
“chrome”: “73.0.3683.121”


Version: 0.12.4
“firstBoot”: false,
“juliaPath”: “C: … \bin\julia.exe”,
“uiOptions”: {
“enableMenu”: true,
“enableToolBar”: true


Version: 0.12.3


Version: 0.3.0
“disable”: true


Version: 0.19.3

language-weave:not installed


Version: 0.4.0


Version: 0.3.6

Could not connect to Julia.