Installation Fails


#1

Hi,

on my windows machine I installed first Julia (v0.6.2) and afterwards downloaded and installed atom (v1.23.3) and then installed the newest Version of uber-juno (v0.1.2). I have the problem that julia does not start inside atom. The prompt “Press Enter to start Julia” comes and when I press enter just nothing happens … The progress bar in the left is also not continuing to run. What can I do? I am on a Windows 7 Enterprise.

Thanks!


#2

Not sure about atom, but in vscode you have to point the extension at julia via a property like…

"julia.executablePath": "C:/Users/person/AppData/Local/Julia-0.6.2/bin/julia.exe"

#3

That is set correctly … and I could for example start the Julia Terminal from inside Atom. But the Julia Console and so on does not work.


#4

I just installed atom/juno and it looks like when you see that press enter to start julia message (after like 30 seconds on my machine) it starts to download a lot of stuff from the internet. Are you behind a proxy that might cause issues with that connection?

Just suggesting items but someone who is skilled with juno might have to chime in.

juno-msg-installingINFO: Cloning cache of ASTInterpreter2 from https://github.com/Keno/ASTInterprete
r2.jl.git
INFO: Cloning cache of Atom from https://github.com/JunoLab/Atom.jl.git
INFO: Cloning cache of Blink from https://github.com/JunoLab/Blink.jl.git
INFO: Cloning cache of CodeTools from https://github.com/JunoLab/CodeTools.jl.git
INFO: Cloning cache of DebuggerFramework from https://github.com/Keno/DebuggerFramework.jl.git
INFO: Cloning cache of Distances from https://github.com/JuliaStats/Distances.jl.git

#5

All the packages are installed. I installed directly via Julia (outside atom) the package atom.jl with all its dependencies. But even this did not help!

I am in a university network, but it does not seem as a problem with the connection to the outside but a problem of the communication with atom and julia. But the julia path is set correctly.


#6

I just repeated this workflow that I used earlier in the office at home and it worked again for me. Both of my machines are Windows10 but that shouldn’t effect atom / julia.

  • Julia 6.2 was installed from https://julialang.org/downloads
  • Download and install atom from https://atom.io/
  • Start atom
  • Open settings with control-,
  • Click install
  • Search for juno
  • Install juno 1.2 (magic happens)
  • Click yes for standard layout when it comes up
  • Click in the REPL box
  • Hit enter

With a lot of magic it just works. Since yours is not I suggest the following clean install procedure and then try the install above again.

  • Uninstall Atom from Add/Remove Programs
  • Uninstall Julia from Add/Remove Programs
  • Delete c:\users<your username>.atom
  • Delete c:\users<you username>.julia

#7

I tried this and it did not help anything …


#8

The crash Report ist the following:

[4984:4988:0207/173448.878:VERBOSE1:crash_service_main.cc(78)] Session start. cmdline is [–reporter-url=https://crashreporter.atom.io --application-name=Atom “–crashes-directory=C:\Users\xxx\AppData\Local\Temp\Atom Crashes” --v=1]
[4984:4988:0207/173448.878:VERBOSE1:crash_service.cc(142)] window handle is 0000000000010304
[4984:4988:0207/173448.878:VERBOSE1:crash_service.cc(284)] pipe name is \.\pipe\Atom Crash Service
dumps at C:\Users\xxx\AppData\Local\Temp\Atom Crashes
[4984:4988:0207/173448.878:VERBOSE1:crash_service.cc(288)] checkpoint is C:\Users\xxx\AppData\Local\Temp\Atom Crashes\crash_checkpoint.txt
server is https://crashreporter.atom.io
maximum 128 reports/day
reporter is electron-crash-service
[4984:4988:0207/173448.878:VERBOSE1:crash_service_main.cc(94)] Ready to process crash requests
[4984:5008:0207/173448.878:VERBOSE1:crash_service.cc(317)] client start. pid = 4860
[4984:5008:0207/173450.825:VERBOSE1:crash_service.cc(317)] client start. pid = 5048
[5108:5112:0207/173450.835:VERBOSE1:crash_service_main.cc(78)] Session start. cmdline is [–reporter-url=https://crashreporter.atom.io --application-name=Atom “–crashes-directory=C:\Users\xxx\AppData\Local\Temp\Atom Crashes” --v=1]
[5108:5112:0207/173450.837:VERBOSE1:crash_service.cc(142)] window handle is 0000000000020246
[5108:5112:0207/173450.837:VERBOSE1:crash_service.cc(284)] pipe name is \.\pipe\Atom Crash Service
dumps at C:\Users\xxx\AppData\Local\Temp\Atom Crashes
[5108:5112:0207/173450.837:VERBOSE1:crash_service.cc(288)] checkpoint is C:\Users\xxx\AppData\Local\Temp\Atom Crashes\crash_checkpoint.txt
server is https://crashreporter.atom.io
maximum 128 reports/day
reporter is electron-crash-service
[5108:5112:0207/173450.838:ERROR:crash_service.cc(295)] could not start dumper


#9

That’s probably unrelated.
What happens when you type Pkg.add("Atom"); using Atom into a REPL outside of Atom?


#10

That works without any problem …


#11

Alright then. Can you open the dev console in Atom with Ctrl-Shift-I and post any errors you see there when trying to start Julia in Juno?


#12

The only thing I can see, when I go in the dev console to the console:

Uncaught (in promise) INFORMATION: Es konnten keine Dateien mit dem angegebenen
Muster gefunden werden.


#13

Very weird, but seems to indicate that something’s wrong with your Julia path. What’s the “Julia Path” in Settings > Packages > julia-client > Settings?


#14

Thats what I thought as well … But the Path should be correct as I could start a Julia Terminal from inside atom.

The path is:

T:\Julia\bin\julia.exe

The very strange thing is, that it happened after a complete reinstall … To me it seems that somewhere old installation files are flying around, but I looked around and cannot find any atom stuff.


#15

I had the same problem with Julia0.61. I just remove Julia0.6.1 and install Julia0.6.2. Only encountered one error during install Atom.jl which is caused by one file which cannot be downloaded. I solved it manually downloading it from the web browser. After reinstalling Julia and all related packages, this problem is solved.

Maybe you should remove all related Julia package for Juno and reinstall them.


#16

What happens if you hit Ctrl-Shift-P to open the command pane, type in "Julia Client: New Terminaland then pasteT:\Julia\bin\julia.exe` there?


#17

Thats what I tried and it helped nothing … :frowning:


#18

A new terminal inside atom opens and when I paste inside the terminal T:\Julia\bin\julia.exe Julia starts smoothly. I could then do everything inside Julia.