Julia can not start inside Atom


#1

I can not make Julia run inside Atom.
All the time I receive the following alert:

   Julia could not be started.
We tried to launch Julia from:
C:\Users\user\AppData\Local\Julia-1.0.3\bin\julia.exe
This path can be changed in the settings.


#2

Is this path correct? (looks a little suspicious that the username is user>


#3

yes it is correct!!

PathtoJulia


#4

If you execute julia.exe from the PowerShell or a cmd terminal, does it start?


#5

Maybe the antivirus or firewall are interfering?


#6

I had a related problem that the REPL wouldn’t start inside Atom (not the exact error you got). I uninstalled and reinstalled julia-client, and restarted Atom.


#7

I uninstalled and reinstalled julia-client, and restarted Atom and the same problem continues to occur.


#8

No changes have been made regarding the security of the PC. And under those same conditions in version Julia 1.0.2 it was working without problems


#9

The following two IDEs are very stable and easy to maintain.
(1) VS code with Julia plugin. I almost never encounter software error. VS Code Julia plugin

(2) PyCharm + Julia plugin [(PyCharm Julia plugin)]
(https://plugins.jetbrains.com/plugin/10413-julia)


#10

Thank you,
You could help me set up Visual Studio Code [to run Julia.
I am getting the following alert:

Could not start the julia language server. Make sure the configuration setting julia.executablePath points to the julia binary.


#11

@HerAdri You should click "WORKSPACESETTINGS" as following and make sure the path is correct. VS code has two settings, “User settings” on the left and “workspace setting” on the right. Maybe, when there is only one setting, it just use that one. If you set both, vs code will use the ‘workspace setting’. After changing the setting, restart VS Code.


#12

The alert is maintained after the recommended setting!


#13

It is not the problem of setting. I am using v0.11.0 Beta.2, on windows 10. I have tried Julia0.7, V1.02, and V1.03, there is no problem.

my workspace settings is as follows and you can remove the others and try again.

{
    "julia.executablePath": "C:\\Julia-1.0.3\\bin\\julia.exe"
}

It seems the problem in running terminalserver.jl @davidanthoff would know the details.


#14

What version of the VSCode plugin did you install?

Re the Juno issue: Did you try this?

Try pasting the complete path into a cmd terminal.


#15

Launching Julia from the Visual Studio Code terminal, it works

VSC%26JULIA4


#16

When I try to run a script from VSC in the terminal I receive the alert that I show in the figure


#17

You are using v0.10.3. Maybe you can install the v0.11.0 Beta2. Currently, both the language and IDE are updating. Sometimes, the errors are caused by the version problem. You can download the v0.11 from V0.11 Beta2
Step 1: uninstall the old plugin
Step 2: download the language-julia-0.11.0-beta.2.vsix from Github.
Step 3: Click Install from VSIX... Install the vsix file from vscode as follows.

If it does not work, @davidanthoff would know the reason


#18

Thanks, problem solved !!


#19

Help me.
Please, I still continue without being able to run Julia within Atom. I continue with the same problem:
Julia could not be started.

We tried to launch Julia from:
C: \ Users \ user \ AppData \ Local \ Julia-1.0.3 \ bin \ julia.exe
This path can be changed in the settings.

I have changed the Path in all possible ways, I have insatalod Julia and Atom countless times.
I do not know what else to do!!!


#20

Two things you could try:

  1. Are there any errors in the Atom developer console (open with Ctrl-Shift-I)?
  2. What happens if you start a terminal (e.g. cmd) and paste the complete path you entered in the julia-client settings?