Error: Julia could not be started

I recently updated my mac and I am getting this error since then. I was using using Atom as the editor without any issue before the update.
I tried the followings but none worked so far:

  1. Uninstall/install Julia clients and restarted Atom
  2. Checked the path
  3. Downloaded a new Julia version 1.5 (I also tried older versions)
  4. Removed and downloaded Atom again

I saw in a post that someone said that he got it into work after updating the system environment variables but I didn’t really understand that.

Does Julia without Atom work? Some path/bin/julia should work. That’s the first step, then getting Atom (or VS Code, that you may want to look into) working.

Yes, it does work without Atom but I would like to run it with Atom.

Is that all there is to the error message? What are you using as the Julia path currently? What happens if you use the New Terminal command and start Julia with that exact path?

I’m not sure what changed, I assume some path, but note you may need to install Juno (not just Atom) i.e. continue from step 3.:

You can set the path as shown there, in Juno extension, otherwise it looks in the system path, and you could change it, but you don’t need to go that route, messing with system environment variables, at least not for the IDEs.

Yes, it’s that all.

here is the path:
/Applications/Julia-1.0/Contents/Resources/julia/bin/julia

I can use Julia in Terminal, no issue with that.

Tries that one either but didn’t work.

If you followed that advice I pointed to, then I’m out of ideas:

You may need to add the path to Julia if it is not accessible via the command julia . To do so, go to Packages > Juno > Settings and in the first box for Julia Path insert the path to your Julia installation