I cannot not run juno via atom

Hi, every one, i am new to julia and i wanted to install juno via atom. for the life of me i cannot make it work. this is the first time ever to post something in a forum. i am desperate. My problem:
After installation everthing seems fine julia itself works fine but after trying to open juno it says:
julia is not recognized as an internal or external command, operable program or batch file.
and yes i specified the path correctly
After reopening atom there is no juno in the list of packages. i googled everthing, tried every solutions suggested in all forum i could find.
Pls can someone help…i have been struggeling with this for more than 5 hours now and i am really close to start crying.

Have you installed Juno via the uber-juno package in Atom?

What od you mean by “no juno in the list of packages”? There is no Atom package called Juno, but rather a number of packages (in the main ink and julia-client) that make up the Atom end of Juno.

Can you run Julia from a shell at the path given in the julia-client settings in Atom?

Hello Florian. First the bad news - there are error reports with Atom/Juno published here. These are normally related to an upgrade.

Now the good news - lots of people are here to help.
I use Windows 10, Atom 1.48-0-beta0 and uber-juno

Hi, thanks for the feedback

yes I installed it via uber juno

in the menu bar there is a drop down menu packages, when i installed uber juno i could select juno/julia in that menu. when i reopen atom, that is gone.

I read all the other entries already and followed there advise, updates reinstall everything…nothing worked.

i dont know what ’ run Julia from a shell at the path given in the julia-client settings in Atom’ means.
as i said i am new to this. the problem is that i cannot access the settings from the juno packages after i reopen atom once. for example i can’t specify the file path…the option is just not there any longer, I also already found another post, that described that problem and as i said tried all the suggested solutions…

Actually I just looked on my system.
In Settings/Packages/Julia Client the Julia Path is set to:
Default : Julia

I remember in the bad old days you had to put an explicit path there, so things are getting better!

Regarding your problem of the package goign missing, I think we might run atom with some debug flag and get it to report whay is happening. I am not an Atom expert.

There is no specific debug flag.
https://flight-manual.atom.io/hacking-atom/sections/debugging/

ok, i managed to get rid of the missing package problem. reinstall everything via the command prompt seems to help, hope that’s useful for someone else.

But i am still at square one with the “julia is not recognized as an internal or external command, operable program or batch file.
and yes i specified the path correctly” problem

Which operating system are you using? I mean if you just open a terminal or shell (e.g. the standard terminal in Linux, whatever terminal exists in MacOS, or PowerShell/cmd in Windows) can you start julia in that terminal by (1) simply typing julia and (2) by specifying the whole path to your Julia executable?

Hi Florian. Knowing your operating system will be useful.
Also can you run apm list

I find tha I cannot run apm in a Windows Powershell, which has pleased me. Not.

Windows 10.
it used to work via the command promt…but now i doesnt and the method to add the path like i did before doesnt work now either…
i

Dont worry please.
Depending on what timezone you are in I would advise a coffee or a beer.

I use the chocolatey package manager in Windows.
I admit I have not used it to install Julia. I am now going to de-install Julia and use Chocolaty to install Julia 1.4.2

OK. Try installing chocolatey
Then open a Powershell window in Administrative mode

chocolatey install julia

Open a powershell without admin privileges
julia

Does this start Julia version 1.4.2 ???

First of all thanks for the great feedback… i really appreciate that.

I think i have it now.
My Steps:

to add the julia path to be able to start it via the command promt, i seems you have to specify the file path to the bin folder not only the folder. that was rather simple…
next install all the julia packages, uber juno, julia client and ink…that didn’t solve. For some reason you have to install the packages FIRST and then add the file path via the command promt. i used admin open for everything. then update to be sure.
for some reason when i used the install manager in atom something went wrong with the packages, when i reopened atom they didn’t work, couldnt change any settings and so forth.
To summarize:
install julia
install atom
install packages via command promt NOT install manager, while atom is closed!
add path, this video should help: https://www.youtube.com/watch?v=UDvviyjdJFU
reopen atom and start juno/julia

hope that helps someone

so i didn’t have to use chocolatey, but i will defintely remember it for future troubleshooting.
Thanks a lot people

Now tell us what exciting things you are going to use Julia for

i am writing my master thesis in bio statistics, and i am a huge math enthusiast. learing new stuff is kind of an obsession for me. so far i have been using python for all calculations, plots and so forth. but i read that julia is the hot new stuff when it comes to data analytics, so I thought that this is something I want to learn…after a rocky start, i am ready