Problems installing uber-juno and other packages in atom

I installed julia to a local directory under MS Win 10, and then atom. But I’ve been unable to get atom set up for julia.

As requested in this forum, I posted a bug report to https://github.com/JunoLab/Juno.jl/issues/296. That’s about being unable to install uber-juno. There was no information I could see about why it couldn’t install. > 3 weeks and no response. There are more details there if you need them.

Someone reported a similar problem here, and solved it by installing ink first in a separate step. I tried to do that, but got an error on indent-detective (“check your internet connection.”) My internet connection is fine, though there is a ton of security software running on my machine and probably on the internet gateways.

Any suggestions? I could just skip using atom, but since that seems to be the recommended style I am reluctant. I could use emacs + julia (ESS for emacs has a julia mode), or even try Visual Studio.

Visual Studio is rather heavy-weight, and seemingly not too julia friendly, so that latter doesn’t seem great. I’ve seen various references to Visual Studio Code (which I think is an editor, not an IDE) working with Julia (and VSC has a julia plugin), but I’m unclear if that means the Visual Studio proper will work with it.

Are you behind a proxy server? If so, configure APM (Atom package manager) to not use strict SSL and to use the proxy server’s IP address, rather than a configuration script.

I’m not behind a proxy server that I’m aware of, and I certainly don’t know its IP.

I have also discovered that while I can edit julia files with emacs on MS-Windows, I can’t run julia under emacs because julia doesn’t give a prompt, causing emacs to hang: https://github.com/emacs-ess/ESS/issues/715. This seems reallly weird, since julia does give a prompt when run in other ways. Maybe the banner is confusing things?

I noticed a julia entry had appeared in the top atom menubar. I still couldn’t launch julia from within atom since atom didn’t know where the julia executable was. I entered the path in the settings for julia-client, and things got much better. I can run julia in atom, and the packages I was struggling with now all show as installed.

Speculation: at least part of my troubles arose from my installation of julia in a local directory, rather than system-wide (or maybe my electing not to have the location put on my path–can’t remember if that was an option). As a result the default of “julia” was insufficient to find the executable. It’s also not possible to set the path for julia before installation of the julia package, so this seems like a Catch-22.

If this theory is right, the errors about “check your internet connection” are way off about the real problem.

Considering all the partial and abortive atom package installations, I’m not sure if it set up properly or not. Is there a way to check?

Installing the Atom packages that make up Juno doesn’t require you to have Julia installed, so I think you were just running into problems with over-eager security software or something like that.

Usually that’s a good suggestion. This FAQ entry might also be relevant.

If you can start a REPL session then chances are good that everything is set up correctly.

Thanks for your help. I guess I’m good to go, even though I’m not sure what the problem was. AFAIK the same security software, over which I have little to no control, was running throughout.