Debugging Atom installation

juno

#1

Doing an installation on my office computer (ie the computer is managed by IT guy and I don’t have all the rights), I find it particularly difficult to debug an installation of Juno in Atom that do not work.

In my case, here is what I did:
Installing Julia 5.1 for Windows 64bit.
Installing Atom (proposed AtomSetup-x64.exe freshly downloaded)
In Atom, installing uber-juno.

It makes some window in the top right cornet telling it install stuff, than tells it’s ready.

But, it does not install Atom in Julia, I had to install myself Pkg.add(“Atom”)

The installation of Julia did not add bin path to the windows PATH variable, so I had to ask the IT guy to add it (he did it in front of me and now It is exported, I can type julia in a cmd and have it started).

I tried to reinstall atom and the Juno related packages several times (after each changes like adding Atom.jl and the path variable).

I’m still stuck at the same place:
If I start anything in the Atom console, It just takes forever. So 1+1 just never output anything.
I have no message telling me anything, it just makes the small bar at the bottom left moving like if executing something.

So my main issue is not much that it does not work, but that it doesn’t tell me anything about why it is not working. This is extremely annoying and time consuming to try blindly random stuff on internet in the hope that maybe it is the solution of the current issue or maybe it is just an other problem with similar output.

I tried the Atom console we get from Ctrl+Shift+i, but I have no useful information (just telling me it doesn’t find spell checker).
I also try to launch from the cmd, but it doesn’t output anything there.

Thank you for support.


#2

Can you try typing using Atom in the REPL and pasting the output here?


#3

@pfitzseb using Atom seemed to execute correctly (ie without outputting errors).
I’ll paste the result Monday when I’ll be at work again (and have access to the computer).


#4

@Jon You might as well try downloading JuliaPro, no?
It includes all this stuff.
~5 clicks away from Juliaing on Juno on Windows!

https://shop.juliacomputing.com/Products/?page_id=7435


#6

@miguelraz The idea of an all in one package is interesting, but I don’t really get the need to register to use open source software.

I read a bit more on this Julia pro, they propose a paid enterprise package, which I don’t need for now, and a free one with less (which would be enough), that is not allowed to be used commercially.

So the enterprise package may be interesting later (depends on the evolution of needs), but is not on the scope of current needs. Thanks however for the suggestion, it’s always good to know about knew products that can be of use.


#7

Have you checked that Atom can find the Julia installation?

From Atom, File -> Settings -> Packages -> Julia Client -> Settings

Julia Path
The location of the Julia binary.

Also update the Atom packages (File -> Settings -> Updates -> Check for Updates)


#8

I think this might be a minor usability nit in uber-juno. I had the same thing happen when I installed it. The “problem” is that under the uber-juno package there is a setting called “Disable - don’t run when Atom boots” that is checked initially. If you change this to false (uncheck it) and restart Atom, the needed Juno packages will be installed. I’m not sure if now that you’ve installed some of the required packages manually, the remaining ones would be installed. Maybe you’d be better off uninstalling those and starting over with a freshly installed uber-juno.

As far as the path to Julia goes, once the packages that make up uber-juno are installed, you can go to the julia-client package and set the “Julia Path” to point to the julia.exe.


#9

@pfitzseb There is absolutely no output when I type using Atom in a julia terminal:


#10

@greg_plowman It is to the Default: julia, and I made sure julia is in the path (ie when I type julia in a cmd, it works).

All packages are up to date (this is a fresh install).


#11

@asampal This checked box is the normal behaviour of uber-juno: As I understood, it serves only to install all the stuff then deactivate itself.
So it is unchecked by default because it should have installed the other packages when installing itself, than should not be run again.
This is a handy option to uncheck this in order to restart the installation process. For instance if you have uninstalled an other package, it will see it and reinstall it.

This however do not solve my issue, it does not seem to change much what I already have, even if I remove some of the packages (and it reinstall them).

In julia-client, I tried to set manually the path to the binary (C:\Users\user\AppData\Local\Julia-0.5.1\bin\julia.exe), but it does not seem to help Atom.


#12

Just a wild guess: Could it be a firewall issue? I assume, that Atom and Julia communicate using a socket. And some virusscanners block that by default.


#13

@ufechner7 Your guess is not that wild:

Seems you nailed the issue, now I have to solve it ^^.

Thanks for your wildness ;).


#14

Alright, so the problem seems to be that Julia and Atom can’t communicate, right? We should add a timeout (10s or something) to the initial communication attempt, so you’d at least get some kind of indication what’s wrong.


#15

@pfitzseb yes, this seems to be the problem.

I think it would be in deed a really nice feature to add this timeout with a message on the type “We can find the Julia executable, but can’t communicate with it, you should check your firewall and anti-malware software”.