Atom+Juno vs JuliaPro


#1

Hello,
I’ve been coding in julia for a while using emacs as my text editor.
A few months back, I tried to switch to Atom+Juno. I installed Atom, but if I used to write julia scripts, I would just copy and paste commands in the terminal (not fun). Later I discovered Juno, so I installed it and I was able to run julia commands in Atom (cool). However, this behavior became erratic. Sometimes Atom would freeze and do not run my commands, sometimes it would. It was a gamble whether it was going to work any given day.
So, I would just use Atom for md files or jmd files, and keep coding julia in emacs. Last week, I learned about JuliaPro.
So, my first question: how is JuliaPro different from Atom+Juno that I have already?
And before knowing this answer, I went ahead and installed JuliaPro. It works amazing, until it doesn’t. I suspect that there is something going on with my computer having Atom+Juno and JuliaPro, because sometimes the JuliaPro logo becomes the Atom logo and I am back to the old Atom+Juno window (I identify it because of the font size that I had modified when using Atom+Juno). When I am back to the old Atom+Juno, my commands do not run sometimes. When I am in the “JuliaPro” logo, my commands run all the time.
Should I uninstall Atom before installing JuliaPro? I tried to find this information in the documentation, but couldn’t.
Sorry if my question is too silly, or not well-explained.
Thanks!


#2

I’m on Windows 10. I have had a few Atom freezes, irrespectively of whether started as JuliaPro or simply as Atom.
These days I run Atom and Julia in the git bash. The evaluation of expressions in such is a little bit less convenient than when it is integrated, but then I am on Julia 0.7 which means unfortunately that Julia and Atom argue a lot.

I’ve never had problems with evaluation of commands not working though. You may wish to check the versions of the packages: sometimes there are issues with newer packages, sometimes with older. Here you have a clue: in one version of Atom the commands work. See if you can find differences between the packages, if there are any that might be a clue as to what goes wrong.


#3

Thank you for your reply!
Yes, I should probably had included more information. I am using a Mac Pro 2017, with Sierra OS. I am using Julia 0.6, and atom 1.21.0, and Julia Pro 0.6.0.1. I have noticed the commands not working even with the same version of the packages, i.e. I am using Atom happily, close and open the same day and commands stop running. This is driving me crazy. But I will try to find more clues, as you suggest. Thank you:)


#4

If Atom is giving you troubles you might want to look into Visual Studio Code. It also has a nice Julia extension.


#5

Just for overcome the idea that Juno is slow and buggy, on Ubuntu it works really great, without any problem (well… I don’t use it to load huge data files, just code files, and I am still waiting for the multiple-plots panel :slight_smile: )


#6

Thanks a lot for the suggestions! I had not heard of Visual Studio Code. I will give it a try! I also have an older Ubuntu machine, so I will test Atom there as well. By the way, JuliaPro does have a plots panel, but maybe I need to uninstall my previous Atom+Juno configuration for it to work properly. I will keep testing, thanks!


#7

I tried Visual Studio Code with the Julia extensions and am quite pleased with it.

Just don’t tell my 1990’s self that I now use an editor originally created in the Evil Empire of Microsoft. It is now freely available and open source (for some definition of “open source”).


#8

VS Code should fall under pretty much all definitions of open source. It is developed in public with an MIT license.


#9

Just don’t tell my 1990’s self that I now use an editor originally created in the Evil Empire of Microsoft. It is now freely available and open source (for some definition of “open source”).

Something to ease your mind :smiley: : https://octoverse.github.com/ (look at the “Organizations with the most open source contributors”)


#10

Silly question: In Visual Studio Code, how do you get the lambda symbol in the editor when typing \lambda. Tab does not seem to work for me. In terminal, tab works fine. Thanks!


#11

For me tab seems to work fine. Which version of the Julia extension are you using? Do you get any code completition when writing \lambda? I assume you have already saved your file as a Julia file or changed the language mode to Julia,


#12

I am using the Julia extension 0.7.0, and my file is a .jl file, so it is recognized as julia file. I am able to write code in the editor and run specific lines in julia with control+return without any problem. However, when I type \lambda and then tab in the editor, I do not get the lambda symbol. Tab simply works as tab (adding space after \lambda). If I change to the terminal window, then \lambda+tab does produce the lambda symbol. But not in the editor. This is annoying because I need to include things like f.λ in my script, but I need to write in the terminal and copy to the editor, instead of being able to write directly in the editor, if this makes sense.


#13

This has been fixed in 0.8.0. You can download a beta version of the extension on its github site.


#14

Great, thanks! One thing to note is that even in version 0.8.0 I cannot use tab to get symbols if I have “C/C++ for Visual Studio Code” extension enabled.


#15

Is it common problem of long and buggy precompilation in JuliaPro?
Especially Plots package is very unstable - takes minutes to precompile and it doesn’t find gui to show plot, if workspace() is called earlier. Onse it even plotted in my Chrome window (with plotly).