Installed Julia Pro reverts to "generic" Atom


#1

After downloading and installing Julia Pro on my Mac, I open it, change the themes, edit my Julia function, and quit. When I re-open Julia Pro, it has turned into some generic Atom with no Julia menu. Re-installing Julia yields the same result, okay at first but then Julia disappears after the first or second re-opening.

Thanks for your help.


#2

Can you please email the contents of config.CSON file to JuliaPro@juliacomputing.com , this file should be located in following path:

/Applications/JuliaPro-0.6.2.1.app/Contents/MacOS/JuliaPro-Juno-0.6.2.1.app/Contents/Resources/julia_atom_0.6.2.1/config.CSON

#3

Thanks for your help. See below.

Freds207MBP2514:julia_atom_0.6.2.1 fredjhickernell$ more config.cson
"*":
“autoupdate-packages”:
frequency: 17520
lastUpdateTimestamp: 1477475645507
core:
automaticallyUpdate: false
telemetryConsent: "no"
themes: [
“one-light-ui”
“one-light-syntax”
]
titleBar: "custom"
versionPinnedPackages: [
“tool-bar”
“default-language”
“latex-completions”
“language-julia”
“ink”
“julia-client”
“autoupdate-packages”
“project-manager”
]
“default-language”:
defaultLanguage: “Julia"
editor:
fontSize: 13
scrollPastEnd: true
showIndentGuide: true
"exception-reporting”:
userId: "07b22838-1dc1-4e48-b5bd-46fd426ab543"
“julia-client”:
enableMenu: true
enableToolBar: true
juliaOptions:
bootMode: "Cycler"
juliaPath: “/Applications/JuliaPro-0.6.2.1.app/Contents/Resources/julia/Contents/Resources/julia/bin/julia"
launchOnStartup: true
useStandardLayout: true
"tool-bar”:
position: "Left"
welcome:
showOnStartup: false
Freds207MBP2514:julia_atom_0.6.2.1 fredjhickernell$


#4

Can anyone help?


#5

Re-installing Julia yields the same result, okay at first but then Julia disappears after the first or second re-opening

Did you mean, reinstalling JuliaPro? Because JuliaPro uses a dedicated installation of Julia that’s located in following path:

/Applications/JuliaPro-0.6.2.1.app/Contents/Resources/julia/Contents/Resources/julia/bin/julia

Reinstalling this Julia might corrupt your JuliaPro installation.

We set ATOM_HOME environment variable before starting Atom using a shell script located in following path: /Applications/JuliaPro-0.6.2.2.app/Contents/MacOS/JuliaPro, this issue might have occurred if ATOM_HOME is not pointing to the right location.

  • Do you have a system level environment variable named ATOM_HOME?

  • Can you please post the contents of following file?

/Applications/JuliaPro-0.6.2.2.app/Contents/MacOS/JuliaPro

If reinstalling JuliaPro is an option? I would suggest you to completely remove the contents of following directory

/Applications/JuliaPro-0.6.2.2.app

and reinstall JuliaPro using .Pkg file you downloaded from Julia Computing website.


#6

To be clear (and correct), I am only talking about JuliaPro. Sorry for the confusion.

I did re-install JuliaPro from the downloaded .pkg after deleting the original JuliaPro app and a stray copy of Atom from my Mac. For the re-installed copy, all seemed to work fine through several open and quit cycles until I added JuliaPro to my Mac dock and started it from there. Then I lost Julia again.

Sorry, I am not a good at Linux. I do not know about “system level environments”

Here is the contents of the file you requested:

#!/bin/sh

ROOT="{0%/JuliaPro}" osascript 2>&1>/dev/null <<EOF do shell script ("export ATOM_HOME={ROOT}/…/MacOS/JuliaPro-Juno-0.6.2.1.app/Contents/Resources/julia_atom_0.6.2.1 && {ROOT}/../MacOS/JuliaPro-Juno-0.6.2.1.app/Contents/Resources/JuliaPro-Juno-0.6.2.1/Contents/MacOS/Atom *")
EOF

Can you help?


#7

We are still trying to determine the cause, please follow these steps and share the result.

  1. Close JuliaPro (Right click on JuliaPro icon in Mac Dock and quit)
  2. Take a take a backup of following file and open this file in a text editor
/Applications/JuliaPro-0.6.2.1.app/Contents/MacOS/JuliaPro
  1. Replace the contents of above file with following code
#!/bin/sh
echo "$ATOM_HOME"> "/tmp/julia.txt"
ROOT="${0%/JuliaPro}"
echo "Within OSA script" >> "/tmp/julia.txt"
osascript 2>&1>/dev/null <<EOF
    do shell script ("export ATOM_HOME=${ROOT}/../MacOS/JuliaPro-Juno-0.6.2.1.app/Contents/Resources/julia_atom_0.6.2.1 && echo \"inside osa ..\" >>/tmp/julia.txt && env >> /tmp/julia.txt && ${ROOT}/../MacOS/JuliaPro-Juno-0.6.2.1.app/Contents/Resources/JuliaPro-Juno-0.6.2.1/Contents/MacOS/Atom $*")
EOF
echo "After execution">> "/tmp/julia.txt"
echo "$ATOM_HOME">> "/tmp/julia.txt"
  1. Open JuliaPro from /Applications (Double click on JuliaPro Icon) and wait until the layout gets loaded completely
  2. Close JuliaPro (Right click on JuliaPro icon in Mac Dock and quit)
  3. Share following text file with us: /tmp/julia.txt

#8

Thank you for your help. Here is the file you requested.

Within OSA script
inside osa …
SHELL=/bin/bash
TMPDIR=/var/folders/rx/3w42kr8d7z34kmsgpb5r9c4c0000gn/T/
Apple_PubSub_Socket_Render=/private/tmp/com.apple.launchd.IiBa51WF3l/Render
ATOM_HOME=/Applications/JuliaPro-0.6.2.1.app/Contents/MacOS/…/MacOS/JuliaPro-Juno-0.6.2.1.app/Contents/Resources/julia_atom_0.6.2.1
USER=fredjhickernell
SSH_AUTH_SOCK=/private/tmp/com.apple.launchd.Lsrrlcyen4/Listeners
__CF_USER_TEXT_ENCODING=0x1F5:0x0:0x0
PATH=/usr/bin:/bin:/usr/sbin:/sbin
PWD=/
XPC_FLAGS=0x0
XPC_SERVICE_NAME=0
HOME=/Users/fredjhickernell
SHLVL=2
LOGNAME=fredjhickernell
_=/usr/bin/env
After execution


#9

FYI, when I keep JuliaPro on my Mac dock and start JuliaPro from my Mac dock, the file Julia.txt is not re-created in /tmp. And in this case I get Atom without Julia. When I quit JuliaPro and start JuliaPro from /Applications/JuliaPro again, Julia re-appears. Hope that this helps.


#10

Any more thoughts from the community? This still has my stymied.


#11

I have found JuliaPro to be sort of hacked together and not super reliable. Could you just install regular Atom + uber-juno, and julia? I have had no stability problems with that.


#12

Willing to try, but do not know how to do what you just suggested. Can you give me some pointers?


#13

Here’s how: https://github.com/JunoLab/uber-juno/blob/master/setup.md

You’ll need to install Julia and Atom separately, and then from Atom install the uber-juno package.

Atom is just a text editor. Juno is a package for Atom, to make it work better with Julia. You can read more about it here: http://junolab.org/


#14

This is happening for me too, I downloaded JuliaPro… installed. First few times it worked fine and I see the Julia specific menu… but after a while maybe a reboot… etc it becomes a generic ATOM