Atom/juno deletes Julia bin folder and then cannot find the path

juno
installation

#1

Hello everyone.

I started learning Julia a while ago and installed 0.5.2. along with Anaconda, IJulia and Atom. I have to say I am a newbie in all this (other than that long time Matlab programmer, but new to Github and terminals :)).

Everything was working fine with my installation. I followed step by step these instructions and tried both Jupyter and Atom/Juno which were working.

I left it for a while and yesterday came back to all of this. I decided to install Julia 0.6.2. Since then I’ve spent hours and nothing is working anymore, therefore my call for help.

After about several tries to get Julia 0.6.2. in atom I decided to uninstall Atom (also deleted the leftover files), uninstall Julia and try everything all over again. Here is what happens.

  1. I install Julia (having uninstalled previous installation and deleted User/.julia and User/Appdata/Local/julia-0.6.2). Then restart. The terminal opens and everything works. Julia is installed in User/.Appdata/Local/julia-0.6.2 and .exe is in User&Appdata/Local/julia-0.6.2&bin
  2. I install Atom
  3. From within Atom I search for uber- juno and install it. It installs without problems.
  4. I try to start Julia and it tells me that it cannot find the path specified (“User/Appdata/Local/julia-0.6.2&bin”). When I navigate to the folder, in the bin folder the exe is missing, only dlls are there, as if Atom deleted it.

Trying to install julia again does not work, when I click on the installation file (or download it again from https://julialang.org/downloads/) it simply does not work. It shows briefly the window that is unpacking anything but doesn’t show extracting any files and it stops.

I can install it in a different path but then it does not work.

I am on Windows 10 with latest upgrades (which might have broken the whole thing). I have tried the above probably 20 times but it still does not work, while it was working before. I suspect when I unsinstall Julia or atom there are leftover files which then point to weird places but this cannot be the whole story.

Any help appreciated


Hydrogen broke Juno-julia-atom
#2

This seems like an issue with your virus scanner to me – I’m very sure that the Juno installation can’t delete the Julia executable.

I can install it in a different path but then it does not work.

What doesn’t work then? You can adjust the path to the julia executable in Atom (Settings > Packages > julia-client > Julia Path).


#3

Regarding the Antivirus I use Avast and it didn’t have any problems previously. This happens when I intall “uber- juno” from within the Atom editor, after installing the editor.

I can reproduce the problem every time on the computer, but on a clean install (I have another computer and I just tested it) everything works fine.

To me this is some mixup between old and new installations and it seems that the uninstaller(s) are not clean enough. That is why I manually delete folders afterwards.

Regarding the install on different path, I install it, I point Atom to the new place and when I open the REPL within Atom/Juno clicking enter on "“Press Enter to start Julia” does nothing. This is what I meant by doing “it doesn’t work”.

Edit: I take that back. I copied the missing executable from the clean installation on the other computer (LLVM.dll was also missing), disabled the antivirus and reinstalled Atom (again by deleting the folder after uninstall). Then I installed uber- juno and it seems to work.

Thanks!


#4

Great, glad you got it working :slight_smile:


#5

Me too, I spent 4 hours yesterday evening doing the same thing over and over again. Thanks.


#6

Boris, I use Windows 10 also. I think I have discussed similar problems on here.
I agree - the uninstaller is not clean enough. I looked into this and the reason is that some of the directories need privileged permissions to remove. Even though I am the sole user on my laptop, and can install software etc. my account does not have the enhanced privileges to remove these diectories.

I could not find a good solution to this problem. I think we need to cooperate and look at the Windows 10 install/deinstall process. I am happy to cooperate with you here.


#7

I think that the case that some directories need privileges has a really simple solution.

Installers, that rely on writing in such directories should not have such directories as default choice!

I run on this issue everyday with Matlab on my work computer, where it insists on writing the startup file (a file that defines paths and general stuff) always in a place where I do not have permissions, and always looks for this file there. Thus, I can neither change the file, nor move it anywhere else. This, IMHO is idiotic.

If I install Matlab on another drive (for example), then it simply works. I mean, Atom, for example does not even allow me to install it anywhere than the place it wants to be installed.