Woe is me. For I have installed Julia, then tried to set up Atom with Juno, and on starting up the Console REPL this is what I got. What should I do to fix this? I’m a bit troubled that it seems to have failed on a clone from github :frowning:

Press Enter to start Julia.

Hold on tight while we're installing some packages for you.
This should only take a few seconds...

   Cloning default registries into C:\Users\--\.julia\registries
   Cloning registry General from "https://github.com/JuliaRegistries/General.git"
ERROR: LoadError: failed to clone from https://github.com/JuliaRegistries/General.git, error: GitError(Code:ERROR, Class:Net, malformed URL ';PROXY')
 [1] pkgerror(::String) at C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.0\Pkg\src\Types.jl:120
 [2] #clone#2(::String, ::Base.Iterators.Pairs{Symbol,LibGit2.CachedCredentials,Tuple{Symbol},NamedTuple{(:credentials,),Tuple{LibGit2.CachedCredentials}}}, ::Function, ::String, ::String) at C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.0\Pkg\src\GitTools.jl:102
 [3] #clone at .\none:0 [inlined]
 [4] (::getfield(Pkg.Types, Symbol("##50#54")))(::LibGit2.CachedCredentials) at C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.0\Pkg\src\Types.jl:927
 [5] shred!(::getfield(Pkg.Types, Symbol("##50#54")), ::LibGit2.CachedCredentials) at .\secretbuffer.jl:184
 [6] #registries#49(::Bool, ::Function) at C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.0\Pkg\src\Types.jl:923
 [7] registries at C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.0\Pkg\src\Types.jl:907 [inlined]
 [8] macro expansion at .\logging.jl:307 [inlined]
 [9] update_registry(::Pkg.Types.Context) at C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.0\Pkg\src\API.jl:96
 [10] #handle_repos_add!#31(::Bool, ::Nothing, ::Function, ::Pkg.Types.Context, ::Array{Pkg.Types.PackageSpec,1}) at C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.0\Pkg\src\Types.jl:593
 [11] #handle_repos_add! at .\none:0 [inlined]
 [12] #add_or_develop#13(::Symbol, ::Bool, ::Base.Iterators.Pairs{Union{},Union{},Tuple{},NamedTuple{(),Tuple{}}}, ::Function, ::Pkg.Types.Context, ::Array{Pkg.Types.PackageSpec,1}) at C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.0\Pkg\src\API.jl:54
 [13] #add_or_develop at .\none:0 [inlined]
 [14] #add_or_develop#12 at C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.0\Pkg\src\API.jl:29 [inlined]
 [15] #add_or_develop at .\none:0 [inlined]
 [16] #add_or_develop#11(::Base.Iterators.Pairs{Symbol,Symbol,Tuple{Symbol},NamedTuple{(:mode,),Tuple{Symbol}}}, ::Function, ::Array{String,1}) at C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.0\Pkg\src\API.jl:28
 [17] add(::String) at .\none:0
 [18] top-level scope at C:\Users\u0159027\.atom\packages\julia-client\script\boot_repl.jl:19
 [19] include at .\boot.jl:317 [inlined]
 [20] include_relative(::Module, ::String) at .\loading.jl:1038
 [21] include(::Module, ::String) at .\sysimg.jl:29
 [22] exec_options(::Base.JLOptions) at .\client.jl:229
 [23] _start() at .\client.jl:421
in expression starting at C:\Users\--\.atom\packages\julia-client\script\boot_repl.jl:1
1 Like

@Neonlights Did you meanwhile solve the issue?
I remember having problems with setting up atom as well. The uber-juno package did not work properly.

If I recall it properly, I solved it by basically installing all the packages manually that are usually installed automatically by uber-juno. This idea was based on this thread, especially this comment.

Furthermore, make sure you add the Atom package in julia’s REPL, before running Atom.

@Neonlights error is unrelated to what you’re proposing since it happens inside Julia.

There seems to be something wrong with the pacakge manager on your Julia install. Can you open Julia outside of Juno and type in ] add Atom, @Neonlights?

I’m having precisely the same problem as @Neonlights, and it’s been driving me bananas. Same circumstances as his. Here’s what I get in a Julia terminal outside of Atom/Juno:

And here’s what I get when starting up Julia in Juno:

Any help resolving this immediate impediment to using Julia (and Juno) would be greatly appreciated (I’m very interested in the language and its environment), including possible workarounds, perhaps consisting of manually cloning packages to locations where Julia and/or Atom/Juno will look for them, thereby obviating (hopefully) the system’s need to clone from GitHub. But what would be the right way to do that? I’m trying various things, none of which seem to have worked so far … Many thanks!

Are you behind a restrictive proxy?

A possible workaround is manually git cloneing https://github.com/JuliaRegistries/General.git into ~/.julia/registries. After that you might be able to add packages.

I had issues with Atom https/http proxies in the past.

If anyone above is behind a restrictive proxy, they should look at this and may want to play around with combinations of https/http proxy. It turned out that for some reason apm wanted me to set my http proxy as the https proxy. I don’t know why but this was the only way that I got apm to work behind my proxy.

1 Like

@Juser, my experience with Julia and JuliaPro on Windows 10 has been similar. To get Pkg to work, I had to set the system environment variable HTTPS_PROXY using “http://” (same as HTTP_PROXY) rather than “https://”. Seemed odd, but it worked! (Will forward a link to the tip, if I find it.)

1 Like

Thanks for your reply, @pfitzseb. Manual cloning didn’t resolve the problem, though for a while it seemed like it might help. However, I came across this secret sauce – to set the HTTPS_PROXY variable as for HTTP_PROXY, using “http://” instead of “https://” – and that seems to have taken care of it!

Interesting that @Juser ran into this wrinkle in the context of apm, the Atom Package Manager. My problem was with Julia’s Pkg.

Hope this helps @Neonlights.


This worked for me! Thanks @IvanFilippenko

I am having a similar problem of Windows 10. Did you set the environmental variables in the usual way? or is this done through Julia? Thank you. John


Juno has been left in maintenance mode, and all users are recommended to switch over to the VSCode extension, which is where all the Juno devs went.

They are basically at feature parity, so it should me a smoother experience.


Thanks Miguel

1 Like