ANN: Juno 0.8.8

Hey folks,

Juno 0.8.8 is out and brings a few new features as well as a couple of bugfixes (thanks to @aviatesk for implementing most of those) :

Features

  • Better conditional breakpoint UX (#562).
  • Custom layouts (#561).
  • Code Formatter (#566).
  • Debug Information (under Julia > Debug Information or with the Julia Client: Debug Info command) (#297).

Bugfixes

  • The debug REPL now supports latex completions (#313).
  • Working directory is set correctly before any user code is evaluated (#316).
  • Line numbers are now correct when evaluating Weave cells (#325).
  • Update do new ssh library that supports newer key formats for remote connections.

Installation

Important : Restart Atom before updating julia-client or ink and do not start a Julia session.

If that does not work, close all Atom instances and type

apm update

into a terminal. If that also doesn’t work, try

apm uninstall ink
apm uninstall julia-client
apm install ink
apm install julia-client

instead.

Package Versions

As always, make sure all Julia and Atom packages are up-to-date:

  • julia-client version 0.8.10
  • ink version 0.10.11
  • Atom.jl version 0.8.8
  • Juno.jl version 0.7.0
17 Likes

First thank you for this however there is a but…sorry. For the past few days I’ve been getting this issue when I start Atom:

The module '/home/josh/.atom/packages/julia-client/node_modules/node-pty-prebuilt/build/Release/pty.node'
was compiled against a different Node.js version using
NODE_MODULE_VERSION 46. This version of Node.js requires
NODE_MODULE_VERSION 69. Please try re-compiling or re-installing
the module (for instance, using `npm rebuild` or `npm install`).

I was hoping the:

apm uninstall ink
apm uninstall julia-client
apm install ink
apm install julia-client

Would fix it, but it doesn’t :frowning:. I’m guessing this is because I’m on Manjaro Linux and too close to the bleeding edge? Although the jump from version 46 to 69 seems pretty big. Has this been seen by others? Is there a work around?

You can find a related issue here: https://github.com/JunoLab/atom-julia-client/issues/570

After upgrading to Juno 0.8.8, I can’t seem to preserve the layout of panes.

I used to have separate panes for each project (with multiple tabs/files for each pane/project).
After upgrading, I rearranged the panes to my liking and all is good.
Then after restarting Atom, all the tabs are in one pane. My custom layout is lost. All is bad.
Looking at the julia-client settings, I can see under Layout->Default Panes section, there is mention of Julia-Client:Restore-Default-Layout.
Is this relevant and if so, how do I access it?

Yes, you’ll definitely want to disable that option – after that Atom’s own (de-)serialization takes over and you should always get back to the window state you had when Atom was closed.

OK thanks. I guess that was my question, how do I disable that option?

By removing that checkmark under julia-client -> UI Options -> Layout:

1 Like

Maybe we should have modified the last statement in the config description since the panes no longer would stay where they previously were anymore.

1 Like

Well that was embarrassingly easy.

Yes, maybe I was assuming the default panes would open without affecting the layout of previously open panes.