Using JupyterLab

#1

Hello,

Since I am a newbie in Julia, I would appreciated if you could provide me the steps on who to make Julia to work in Jupyterlab.

I am running julia 1.1.0 on win10. I use winpython as my python (v3.6) distribution.

Thanks in advance

0 Likes

JupyterLab (beta) is out. Anyone tried it?
#2

Install IJulia and build it:

] add IJulia
build IJulia

After that, run jupyter-lab (e.g. form bash console, not from within julia) and from there choose which notebook to run. Have fun.
The only think I did not get to work (yet) in jupyter-lab (but works with jupyter) is Interact.jl .

1 Like

#3

You can also install it from within julia. That’s smart in particular if you don’t already have jupyter lab installed as it will install it for you.

using IJulia
jupyterlab() # use detached=true if you want to continue using your julia REPL session
3 Likes

#4

add IJulia automatically builds it. You only need to manually run build IJulia if you need to re-build for some reason, e.g. if the location of your Julia installation has moved.

0 Likes

#5

For me it doesn’t work before I refresh my browser window, after which it works just fine (more specifically, the output displays correctly but controls won’t work before I refresh).

You need to have the extension installed as well, of course, as documented.

0 Likes

#6

Thanks for your replies

The answered provided by @mkborregaard worked just fine :slight_smile:

1 Like

#7

That’s a good news. So something got messed up with my installation: I have WebIO but nothing is displayed (while some times ago, probably was Julia 0.6, I had the graph displayed, although controls were ineffective).

0 Likes

#8

Thanks for the information. I get the following every time I execute the commands you list above:

julia> using IJulia
julia> jupyterlab()
install JupyterLab via Conda, y/n? [y]: y
[ Info: Running `conda install -y jupyterlab` in root environment
Collecting package metadata: done
Solving environment: done

# All requested packages already installed.

This works, but it takes a minute for it to decide Jupyterlab is already installed. is there a way to set things up so it doesn’t ask to install via Conda every time?

0 Likes

#9

Hm… seems like every time I open a new Julia session, and do:

julia> using IJulia
julia> jupyterlab()

Julia suggests to (re-) install Jupyter Lab:

julia> jupyterlab()
install JupyterLab via Conda, y/n? [y]: y
[ Info: Running `conda install -y jupyterlab` in root environment
Collecting package metadata: done
Solving environment: done

I assume that I don’t have to answer “y” on this question>?

1 Like