Is IJulia meant to be working with Julia v1.0 yet?

question
jupyter

#1

I’ve been trying to get IJulia/Jupyter notebook to work on my (Windows 10 64 bit) computer. I installed Julia v1.0 (before this I was using Julia v0.6 which worked fine) and then installed IJulia, which gave the following message:

(v1.0) pkg> add IJulia
 Resolving package versions...
  Updating `C:\Users\c1235\.julia\environments\v1.0\Project.toml`
  [7073ff75] + IJulia v1.9.2
  Updating `C:\Users\c1235\.julia\environments\v1.0\Manifest.toml`
  [7073ff75] + IJulia v1.9.2
  [739be429] + MbedTLS v0.6.0
  [c2297ded] + ZMQ v0.6.3
  [7b1f6079] + FileWatching

When I opened Jupyter lab I saw the Julia 1.0.0 kernel as an option and was able to start a Julia notebook. However, when I tried to execute my first cell the computation never finished running, and my Jupyter console showed the following:

C:\WINDOWS\system32>jupyter-lab
[W 18:22:44.692 LabApp] JupyterLab server extension not enabled, manually loading...
[I 18:22:44.708 LabApp] JupyterLab extension loaded from C:\Program Files\Anaconda3\lib\site-packages\jupyterlab
[I 18:22:44.708 LabApp] JupyterLab application directory is C:\Program Files\Anaconda3\share\jupyter\lab
[I 18:22:44.708 LabApp] Serving notebooks from local directory: C:\WINDOWS\system32
[I 18:22:44.708 LabApp] The Jupyter Notebook is running at:
[I 18:22:44.708 LabApp] http://localhost:8888/?token=6cf33937414d8826ffd7cfa74ef5b5c1215177bd9158cf3d
[I 18:22:44.708 LabApp] Use Control-C to stop this server and shut down all kernels (twice to skip confirmation).
[C 18:22:44.724 LabApp]

    Copy/paste this URL into your browser when you connect for the first time,
    to login with a token:
        http://localhost:8888/?token=6cf33937414d8826ffd7cfa74ef5b5c1215177bd9158cf3d
[I 18:22:45.140 LabApp] Accepting one-time-token-authenticated connection from ::1
[W 18:22:49.775 LabApp] Could not determine jupyterlab build status without nodejs
[W 18:22:49.828 LabApp] 404 GET /api/contents/Untitled.ipynb?content=0&1534008169835 (::1): No such file or directory: Untitled.ipynb
[W 18:22:49.828 LabApp] No such file or directory: Untitled.ipynb
[W 18:22:49.844 LabApp] 404 GET /api/contents/Untitled.ipynb?content=0&1534008169835 (::1) 15.65ms referer=http://localhost:8888/lab
[I 18:22:54.219 LabApp] Creating new notebook in /
[I 18:22:59.557 LabApp] Kernel started: bbacda69-c226-46de-a6db-55ec5457d852
[ Info: Recompiling stale cache file C:\Users\c1235\.julia\compiled\v1.0\IJulia\nfu7T.ji for IJulia [7073ff75-c697-5162-941a-fcdaad2a7d2a]
Starting kernel event loops.
[I 18:23:14.173 LabApp] Adapting to protocol v5.0 for kernel bbacda69-c226-46de-a6db-55ec5457d852
[I 18:23:14.193 LabApp] Adapting to protocol v5.0 for kernel bbacda69-c226-46de-a6db-55ec5457d852
[I 18:23:14.204 LabApp] Adapting to protocol v5.0 for kernel bbacda69-c226-46de-a6db-55ec5457d852
[I 18:23:16.066 LabApp] Adapting to protocol v5.0 for kernel bbacda69-c226-46de-a6db-55ec5457d852
[I 18:23:26.074 LabApp] Adapting to protocol v5.0 for kernel bbacda69-c226-46de-a6db-55ec5457d852
[I 18:23:36.086 LabApp] Adapting to protocol v5.0 for kernel bbacda69-c226-46de-a6db-55ec5457d852

I’ve also tried building IJulia, with the following result:

(v1.0) pkg> build IJulia
  Building Conda ──→ `C:\Users\c1235\.julia\packages\Conda\m7vem\deps\build.log`
  Building MbedTLS β†’ `C:\Users\c1235\.julia\packages\MbedTLS\Qo8TN\deps\build.log`
β”Œ Error: Error building `MbedTLS`:
β”‚ ERROR: LoadError: IOError: unlink: operation not permitted (EPERM)
β”‚ Stacktrace:
β”‚  [1] uv_error at .\libuv.jl:85 [inlined]
β”‚  [2] unlink(::String) at .\file.jl:722
β”‚  [3] #rm#9(::Bool, ::Bool, ::Function, ::String) at .\file.jl:253
β”‚  [4] #rm at .\none:0 [inlined]
β”‚  [5] macro expansion at .\logging.jl:317 [inlined]
β”‚  [6] #uninstall#118(::Bool, ::Function, ::String) at C:\Users\c1235\.julia\packages\BinaryProvider\ZbFxn\src\Prefix.jl:409
β”‚  [7] #uninstall at .\none:0 [inlined]
β”‚  [8] macro expansion at .\logging.jl:308 [inlined]
β”‚  [9] #install#115(::Prefix, ::String, ::Bool, ::Bool, ::Bool, ::Function, ::String, ::String) at C:\Users\c1235\.julia\packages\BinaryProvider\ZbFxn\src\Prefix.jl:353
β”‚  [10] (::getfield(BinaryProvider, Symbol("#kw##install")))(::NamedTuple{(:prefix, :force, :verbose),Tuple{Prefix,Bool,Bool}}, ::typeof(install), ::String, ::String) at .\none:0
β”‚  [11] top-level scope at C:\Users\c1235\.julia\packages\MbedTLS\Qo8TN\deps\build.jl:45
β”‚  [12] include at .\boot.jl:317 [inlined]
β”‚  [13] include_relative(::Module, ::String) at .\loading.jl:1038
β”‚  [14] include(::Module, ::String) at .\sysimg.jl:29
β”‚  [15] include(::String) at .\client.jl:388
β”‚  [16] top-level scope at none:0
β”‚ in expression starting at C:\Users\c1235\.julia\packages\MbedTLS\Qo8TN\deps\build.jl:41
β”” @ Pkg.Operations C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.0\Pkg\src\Operations.jl:1068
  Building ZMQ ────→ `C:\Users\c1235\.julia\packages\ZMQ\GA4Xh\deps\build.log`
  Building IJulia ─→ `C:\Users\c1235\.julia\packages\IJulia\9RcVi\deps\build.log`

(v1.0) pkg>

#2

as of right now, it works


Julia Version 1.0.0
Commit 5d4eaca0c9 (2018-08-08 20:58 UTC)
Platform Info:
  OS: macOS (x86_64-apple-darwin14.5.0)
  CPU: Intel(R) Core(TM) i7-6820HQ CPU @ 2.70GHz
  WORD_SIZE: 64
  LIBM: libopenlibm
  LLVM: libLLVM-6.0.0 (ORCJIT, skylake)

#3

Apparently I’m not the only person with this problem. Might be a Windows only issue.



#4

indeed, fails on Windows 7 for me :frowning:


#5

Wanted to make my first steps with Jupyter. However, same issue here… Win10 64 Bit, Julia 1.0. Hints as given above are too complicated, at least for me. Thought, it’s just a straightforward thing with Julia&Jupyter…


#6

IJulia hangs randomly on all three machines I’ve tried it on. All are running Window 10 (64 bit). Sometimes IJulia runs a notebook to completion, but most often it fails part way through. Since I’m just learning Julia, these notebooks are not complicated. I’ve tried the β€œdev IJulia” trick in the package manager suggested in issue #693. Initially that seemed to help, but not so much today.

Thanks to all who are working on this.


#7

I’ve tested IJulia on both Julia 0.7 and Julia 1.0 on Windows 10 (64bit) machines.

  • If I start IJulia, a simple thing like 1+1 doesn’t work, and the notebook hangs.
  • If I interrupt the kernel, and switch to Python 3, there are a few messages flashing in the notebook heading: 1) No kernel in orange text box, 2) Kernel starting, please wait... in white textbox, and finally, 3) Kernel ready in blue textbox – before that message disappears.
  • With Python 3 kernel, operations like 1+1 respond immediately.
  • Switching back to Julia 0.7.0 kernel, the following messages flash in the notebook heading: a) No kernel in orange text box, b) Kernel starting, please wait..., and finally c) Connected in blue textbox.
  • Again, IJulia doesn’t work.

I don’t know if the difference in message is important… Kernel ready when starting Python 3, and the system works… Connected when starting Julia 0.7.0 when the system doesn’t work.

Another observation is that when I start the Python 3 kernel, the message No kernel in orange is shown for some time (5 seconds or so?), while when I start the Julia 0.7.0 kernel, the message No kernel in orange is shown for only a very short time (0.1 second or so?).


#8

I got IJulia to work with Julia v1.0 on Windows 10 by entering the following in the Julia REPL

(v1.0) pkg> add IJulia
ENV["IJULIA_DEBUG"] = true
(v1.0) pkg> dev Ijulia

#9

IJulia 1.9.3 works with Julia 1.0.0 on Linux.

Try running using Pkg; Pkg.update() to get the latest IJulia. That fixed an UndefVarError: srand not defined for me.


#10

I don’t know man, it still hangs for me. (With Julia 0.7.0, Windows 10)


#11

IJulia didn’t work with my installation of Julia 0.7.0 either. I therefore I uninstalled Julia 0.7.0 and deleted the associated directories. I then reinstalled Julia 0.7.0 from scratch.

I opened Julia REPL and ran the following (which is slightly different from what I wrote above).

(v1.0) pkg> add IJulia
julia> ENV["IJULIA_DEBUG"] = true
(v1.0) pkg> dev IJulia
(v1.0) pkg> build IJulia

And IJulia now works with Julia 0.7.0 too on my computer (Windows 10)


#12

No luck for me. I couldn’t even get the damn thing to build:

julia> ENV["IJULIA_DEBUG"] = true
true

(v0.7) pkg> build IJulia
  Building Conda ──→ `C:\Users\PetrKrysl\.julia\packages\Conda\m7vem\deps\build.log`
  Building MbedTLS β†’ `C:\Users\PetrKrysl\.julia\packages\MbedTLS\Qo8TN\deps\build.log`
β”Œ Error: Error building `MbedTLS`:
β”‚ ERROR: LoadError: IOError: unlink: operation not permitted (EPERM)

#13

Sorry to hear that. I don’t know what to suggest next.
Below is a printout of my REPL session after I installed Julia 0.7.0 from scratch. Maybe there is something in there that may help.

              _
   _       _ _(_)_     |  A fresh approach to technical computing
  (_)     | (_) (_)    |  Documentation: https://docs.julialang.org
   _ _   _| |_  __ _   |  Type "?" for help, "]?" for Pkg help.
  | | | | | | |/ _` |  |
  | | |_| | | | (_| |  |  Version 0.7.0 (2018-08-08 06:46 UTC)
 _/ |\__'_|_|_|\__'_|  |  Official http://julialang.org/ release
|__/                   |  x86_64-w64-mingw32

(v0.7) pkg> add IJulia
  Updating registry at `C:\Users\Owner\.julia\registries\General`
  Updating git-repo `https://github.com/JuliaRegistries/General.git`
 Resolving package versions...
 Installed SweepOperator ─────────────── v0.2.0
 Installed PenaltyFunctions ──────────── v0.1.1
 Installed LearnBase ─────────────────── v0.2.2
 Installed TableTraitsUtils ──────────── v0.2.1
 Installed DataValues ────────────────── v0.4.5
 Installed StatsBase ─────────────────── v0.25.0
 Installed IndexedTables ─────────────── v0.7.4
 Installed DataStructures ────────────── v0.11.0
 Installed SortingAlgorithms ─────────── v0.3.1
 Installed TranscodingStreams ────────── v0.8.0
 Installed CodecZlib ─────────────────── v0.5.0
 Installed OnlineStatsBase ───────────── v0.9.0
 Installed WeakRefStrings ────────────── v0.5.2
 Installed Reexport ──────────────────── v0.2.0
 Installed TableTraits ───────────────── v0.3.1
 Installed Dagger ────────────────────── v0.6.2
 Installed Nullables ─────────────────── v0.0.7
 Installed OnlineStats ───────────────── v0.19.1
 Installed IteratorInterfaceExtensions ─ v0.1.1
 Installed Glob ──────────────────────── v1.2.0
 Installed RecipesBase ───────────────── v0.5.0
 Installed LossFunctions ─────────────── v0.3.1
 Installed TextParse ─────────────────── v0.6.0
  Updating `C:\Users\Owner\.julia\environments\v0.7\Project.toml`
 [no changes]
  Updating `C:\Users\Owner\.julia\environments\v0.7\Manifest.toml`
  [9e28174c] - BinDeps v0.8.8
  [b99e7846] ↑ BinaryProvider v0.3.3 β‡’ v0.4.1
  [944b1d66] ↑ CodecZlib v0.4.3 β‡’ v0.5.0
  [34da2185] ↑ Compat v1.0.0 β‡’ v1.0.1
  [8f4d0f93] ↑ Conda v0.8.1 β‡’ v1.0.1
  [d58978e5] ↑ Dagger v0.6.1 β‡’ v0.6.2
  [864edb3b] ↑ DataStructures v0.10.0 β‡’ v0.11.0
  [e7dc6d0d] ↑ DataValues v0.4.2 β‡’ v0.4.5
  [c27321d9] ↑ Glob v1.1.1 β‡’ v1.2.0
  [6deec6e2] ↑ IndexedTables v0.7.3 β‡’ v0.7.4
  [82899510] ↑ IteratorInterfaceExtensions v0.1.0 β‡’ v0.1.1
  [682c06a0] ↑ JSON v0.18.0 β‡’ v0.19.0
  [7f8f8fb0] ↑ LearnBase v0.1.6 β‡’ v0.2.2
  [30fc2ffe] ↑ LossFunctions v0.2.0 β‡’ v0.3.1
  [739be429] ↑ MbedTLS v0.5.12 β‡’ v0.6.0
  [4d1e1d77] ↑ Nullables v0.0.6 β‡’ v0.0.7
  [a15396b6] ↑ OnlineStats v0.18.0 β‡’ v0.19.1
  [925886fa] ↑ OnlineStatsBase v0.8.0 β‡’ v0.9.0
  [06bb1623] ↑ PenaltyFunctions v0.0.2 β‡’ v0.1.1
  [3cdcf5f2] ↑ RecipesBase v0.4.0 β‡’ v0.5.0
  [189a3867] ↑ Reexport v0.1.0 β‡’ v0.2.0
  [a2af1166] ↑ SortingAlgorithms v0.3.0 β‡’ v0.3.1
  [2913bbd2] ↑ StatsBase v0.24.0 β‡’ v0.25.0
  [7522ee7d] ↑ SweepOperator v0.1.0 β‡’ v0.2.0
  [3783bdb8] ↑ TableTraits v0.3.0 β‡’ v0.3.1
  [382cd787] ↑ TableTraitsUtils v0.2.0 β‡’ v0.2.1
  [e0df1984] ↑ TextParse v0.5.0 β‡’ v0.6.0
  [3bb67fe8] ↑ TranscodingStreams v0.5.3 β‡’ v0.8.0
  [30578b45] - URIParser v0.3.1
  [81def892] ↑ VersionParsing v1.1.1 β‡’ v1.1.2
  [ea10d353] ↑ WeakRefStrings v0.4.7 β‡’ v0.5.2
  [c2297ded] ↑ ZMQ v0.6.2 β‡’ v0.6.4
  Building CodecZlib β†’ `C:\Users\Owner\.julia\packages\CodecZlib\wwgbh\deps\build.log`

julia> ENV["IJULIA_DEBUG"] = true
true

(v0.7) pkg> dev IJulia
  Updating git-repo `https://github.com/JuliaLang/IJulia.jl.git`
[ Info: Path `C:\Users\Owner\.julia\dev\IJulia` exists and looks like the correct package, using existing path instead of cloning
 Resolving package versions...
  Updating `C:\Users\Owner\.julia\environments\v0.7\Project.toml`
  [7073ff75] ↑ IJulia v1.9.0 β‡’ v1.9.3+ [`C:\Users\Owner\.julia\dev\IJulia`]
  Updating `C:\Users\Owner\.julia\environments\v0.7\Manifest.toml`
  [7073ff75] ↑ IJulia v1.9.0 β‡’ v1.9.3+ [`C:\Users\Owner\.julia\dev\IJulia`]

(v0.7) pkg> build IJulia
  Building Conda ──→ `C:\Users\Owner\.julia\packages\Conda\m7vem\deps\build.log`
  Building MbedTLS β†’ `C:\Users\Owner\.julia\packages\MbedTLS\Qo8TN\deps\build.log`
  Building ZMQ ────→ `C:\Users\Owner\.julia\packages\ZMQ\yClfT\deps\build.log`
  Building IJulia ─→ `C:\Users\Owner\.julia\dev\IJulia\deps\build.log`
 Resolving package versions...

(v0.7) pkg>

#14

It is a Windows only problem, see https://github.com/JuliaLang/IJulia.jl/issues/693.


#15

Should hopefully be working now once you do a Pkg.update.


Trouble installing IJulia in fresh Julia 1.0
Jupyter Notebook Kernel Failing
#16

I took the following steps to install IJulia and it works both on Julia 0.7 and 1.0 version on Win10. I am using normal installation of Python (not Conda).

  1. ENV[β€œPYTHON”] = specify path to ptyhon.exe
  2. ENV[β€œJUPYTER”] = specify path to jupyter.exe
  3. using Pkg;Pkg.add(β€œIJulia”);Pkg.build(β€œIJulia”)
  4. using IJulia

Hope it helps.


#17

On Windows it is also possible to use IJulia via Conda. However, there is currently a bug in the Anaconda installer for Python 3 that is affecting us, and the workaround is that you need to tell Conda.jl to install using Python 2:

If someone who uses Windows could take the time to file a proper bug report (e.g. by downloading the minconda installer and running it manually to reproduce in a clean example) with Anaconda that would be much appreciated.