WinPython + JupyterLab + Julia 1.5.2 + Julia 1.6.5


Since nearly one year, I have been using WinPython + JupyterLab + Julia 1.5.2
I can’t remember how I managed to configure that at that time.
Using JupyterLab that came with WinPython, I can create Python or Julia 1.5.2 notebooks.
I can use both languages side-by-side, which is very convenient.

Today, I installed Julia 1.6.5 and I added the IJulia package from the REPL.
I expected to see a configuration WinPython + JupyterLab + Julia 1.5.2 + Julia 1.6.5.
But nothing has changed! Julia 1.6.5 doesn’t appear in JupyterLab.
I can use Julia 1.6.5 by lauching JupyterLab from the REPL, but then my Python environment is gone.

Could you help me ?
I would like to use my existing Python environment and the Julia 1.6.5 together



Can you try

using Pkg"IJulia")

At least in normal Jupyter this adds the new Julia version as kernel.


I did that and then

using IJulia

This launches a JupyterLab instance from the Julia 1.6.5 folder.
The nice thing is that both versions of Julia are available.
Unfortunately, I have no acces to WinPython then.
Instead it takes Python from ...\.julia\conda\3 which is fresh new.
I would prefer to use my former WinPython installation with all my stuff!

The JupyterLab packaged with WinPython makes Julia 1.5.2 avaliable.
I can’t remember how I did the install one year ago.

Any idea?
How does a JupyterLab instance know where all the kernels are?



In the documentation is something mentioned

Does that help somehow?


Just had a look at Installation · IJulia
I notied a remark about ENV["JUPYTER"], and was quite exceited!
I then did this:

ENV["JUPYTER"] = "...\\WPy64-3940"
using Pkg

Unfortunately, it didn’t change anything.
But I have the feeling I come close to the solution !
I go to bed, and hopefully I solve that tomorrow !!!

Any suggestion again welcome!



1 Like

Woke up early today!
But not yet a solution!

ENV["JUPYTER"] = "...\\WPy64-3940\\Jupyter Lab.exe"

does not solve the problem …

In the WinPython distribution, I observe there is a notebook called installing_julia_and_ijulia.ipynb.
But it looks like it deals with a very olde version of Julia.
And this script is rather obscure to me, I am not ready to go futher!

Any suggestion still welcome!


This seems to say similar things to what you tried, but maybe something useful?

Interresting thread.
Comes close, but no clue for my issue.

I got it !!!
Thanks to all of you !

I found out that the usual IJulia installation from the Julia REPL
creates a kernel.json file in a folder like :
This where JupyterLab will look for kernels when it is started from the Julia REPL.

But the JupyterLab included in WinPython won’t look there.
Instead, it looks in a folder like :

I simply solved the problem by copying the julia-1.6 folder from the first location to the second.

And now, I am happy!



1 Like