Trying to get remote REPL working between Windows computers

Hi, I’m trying to do use ftp-remote-edit to allow editing and executing code on another machine.

Both machines are running Windows 10 and Julia 1.4.1.

I have openSSH running on the remote machine and I can log in from the local machine using ssh (and run Julia manually) and I can copy files with sftp.

Inside Juno on the local machine, I set up the info for the remote machine, and I can view the directory structure of the remote machine, so Atom is successfully accessing the remote computer. However, when I try to open a file, I get an error like:

ENOENT: no such file or directory, open

I assume the D: in the middle of that path (present because the remote machine is a windows box!) is invalid in the path name and prevents the file from actually getting copied to the local temp folder.

In addition, when I try to run the remote REPL, I get a different error, coming from remote.js.

Both of these errors show up briefly in a popup window, but other than doing a quick screen capture, I’m not sure where to find them to copy/paste. For the file errror, not a big deal, but for the error in remote.js, it’s a lot of text and much of it doesn’t fit in the popup.


Juno doesn’t support connections to Windows servers at the moment. Also see

So if I run linux in a VM on the remote host, is using that supported from a local Windows instance?

I’m trying something a little simpler - running Julia in Windows Subsystem for Linux.

I’ve got the remote file stuff working. I can add directories, create new files, edit them across sftp.

When trying to Start Remote Julia Process, I get

Remote Julia session could not be started.
We tried to launch Julia from julia but the process failed with 127.
Please make sure your settings are correct.

If I ssh to the remote machine, I can just type julia and the interpreter runs, so I’ve got the path set up.

Any thoughts?

[EDIT: Also, is it possible in general to have a local REPL and a remote REPL operational simultaneously?]