Connecting to Remote REPL on Atom

I am trying to connect a remote Julia session using atom. I want to be able to use the REPL when I run my code. I have been following closely the tutorial laid out in the official documentation (Connecting to a Julia session on a remote machine · Juno Documentation), but still appear to be running into some problems.

I have successfully installed “ftp-remote-edit” package on Julia and linked to the server. I can access files on the server in Atom. I can also open a remote terminal instance inside of atom.

What I cannot do: I can’t open a “Remote Julia Process” (Juno → Start Remote Julia Process). When I do, I get the following error: " Remote Julia session could not be started. We tried to launch Julia from julia but the process failed with 1 . Please make sure your settings are correct.". When I searched the error, I didn’t get anything that was particularly helpful. The REPL also spits out some weird errors. They are:
“Unmatched ‘’’.
#: Command not found.
if: Expression Syntax.
Badly placed ()'s.
else: endif not found.”

I’ve also attached a picture of what I am seeing.

I’m not really sure what to make of it and I don’t have the slightest idea of where to start to fix this issue.
If anyone has any suggestions I would really appreciate them!

Thank you!