Manual port forwarding to use REPL

I am presently trying to use Atom editor to connect to a remote desktop server. I used the instructions from the link https://docs.junolab.org/latest/man/remote/. I was successfully able to use ftp-remote-edit to remotely edit codes in the server machine (covered in Basic setup section). When I tried to do the same for REPL in my Atom editor (covered in Manual port forwarding section), I am unable to get any output. The REPL process keeps on going as shown in the figure.
image

Can anyone help?
I am using Atom editor in Windows 10 to connect to Julia in Ubuntu 16.04.

Hello @SambitMishra98 I have Windows 10 and Ubuntu VMs available and the Atom editor.
However I am a bit busy atht ht emoment… will try when I have a bit of time

1 Like

Why do you need to use manual port forwarding instead of the automatic setup Juno provides for you?

2 Likes

I didn’t get you. What do you mean by ‘automatic setup’?
I have a desktop server in the office which has 20 cores and a GPU. While I code in Julia, I check if each of the lines work using REPL. For example, I want to run the codes given in https://juliagpu.gitlab.io/CUDA.jl/tutorials/introduction/ this way.

Just follow the instructions at https://docs.junolab.org/latest/man/remote/#Basic-setup-1 instead of those at https://docs.junolab.org/latest/man/remote/#Manual-port-forwarding-1.

2 Likes

Yes, I did that. I was able to connect to the remote server for editing the files only. As you can see in the image below, I am connected to the i9quadro desktop server and am able to run the programs using Julia in the terminal below. I am however not able to run individual lines of code this way by pressing Ctrl+Enter. Based on the tutorial, this is possible if I do the manual port forwarding. Am I missing something trivial here?

Did you make sure to start the remote REPL as instructed? It should open a REPL @ i9quadro tab.

1 Like

Yea I followed the instructions blindly, and it didn’t work. I then tried to read up on each of the instructions and couldn’t get anywhere. Based on the screenshots in the link I realised I am supposed to get a REPL @ i9quadro tab, but I couldn’t get it.

What happens when you execute the Start Remote Julia Process command (either from the command pane or the toolbar)?

1 Like

YESSSSS !!! IT WORKED !!! THANKS A LOT !!!

I probably did not realise that it was working and had skipped that :sob:

Thanks a lot @pfitzseb !!!

Great, glad it’s working for you :slight_smile: