Trouble with Basic Setup

I followed these instructions to install Julia and Juno:
I’m using Windows 10. I followed Steps 1-3 successfully. In the settings for the package “julia-client”, the path points to julia.exe.

However, in step 4, Packages > Julia > Open Console doesn’t exist. There is only Packages > Juno, and the option Open Console isn’t in this menu.

When I start Atom, the REPL pops up. I can get Julia to start in this pane. However, I can’t get code from a file to output into this pane. When I press ctrl+enter or the lightning bolt icon, diagonal lines appear as if it is running, but nothing appears in the REPL pane. Further, when I define a variable, such as a=1, in the REPL pane, nothing appears in my workspace. Here is a screenshot:

I found another post that seemed to have a similar issue, but the solution isn’t working for me: Unable to run blocks in Juno

  • Juno > Open Console doesn’t exist for me in the menu.
  • I did not change any key bindings
  • Cell evaluation does not work
  • When I press ] then type status, here is the output:

(v1.2) pkg> status
Status C:\Users\User\.julia\environments\v1.2\Project.toml
(empty environment)

With the latest Juno version, we renamed Open Console into Open REPL, so you may be able to find that instead. (and we need to update our doc)

This is intended behaviour, but if you want to show results in REPL instead of inline-results in an editor, you can change 'Result Display Mode' setting in UI Options into console instead of inline.

That’s weird. The workspace view is supposed to get updated after any code ran in REPL. Try clicking the cycle icon on the top right.

Thanks for the response. Unfortunately I don’t see inline-results either. The code in the editor does not seem to output anywhere.

That’s weird. The workspace view is supposed to get updated after any code ran in REPL. Try clicking the cycle icon on the top right.

The workspace view is still empty after defining a variable and cycling.

Sounds like some setup has been broken. Can you give a dubug info from Juno → Debug Information menus ?

Nothing shows up after clicking Juno > Debug Information.

This is the output from pressing enter in REPL after opening Atom:

Hold on tight while we are installing some packages for you.
This should only take a few seconds…

Activating environment at C:\Users\User\.julia\environments\v1.2\Project.toml
Cloning default registries into C:\Users\User\.julia
Cloning registry from “
Fetching: [> ] 0.0 %

[8] parsefile at C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.2\Pkg\ext\TOML\src\TOML.jl:46 [inlined]
[9] #read_registry#134(::Bool, ::typeof(Pkg.Types.read_registry), ::String) at C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.2\Pkg\src\Types.jl:1049
[10] read_registry at C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.2\Pkg\src\Types.jl:1044 [inlined]
[11] clone_or_cp_registries(::Pkg.Types.Context, ::Array{Pkg.Types.RegistrySpec,1}, ::String) at C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.2\Pkg\src\Types.jl:1021
[12] clone_or_cp_registries at C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.2\Pkg\src\Types.jl:987 [inlined]
[13] clone_default_registries() at C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.2\Pkg\src\Types.jl:937
[14] find_registered!(::Pkg.Types.EnvCache, ::Array{String,1}, ::Array{Base.UUID,1}) at C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.2\Pkg\src\Types.jl:1216
[15] registry_resolve!(::Pkg.Types.EnvCache, ::Array{Pkg.Types.PackageSpec,1}) at C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.2\Pkg\src\Types.jl:854
[16] #add#25(::Bool, ::Base.Iterators.Pairs{Union{},Union{},Tuple{},NamedTuple{(),Tuple{}}}, ::typeof(Pkg.API.add), ::Pkg.Types.Context, ::Array{Pkg.Types.PackageSpec,1}) at C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.2\Pkg\src\API.jl:92
[17] add at C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.2\Pkg\src\API.jl:69 [inlined]
[18] #add#24 at C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.2\Pkg\src\API.jl:67 [inlined]
[19] add at C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.2\Pkg\src\API.jl:67 [inlined]
[20] #add#21 at C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.2\Pkg\src\API.jl:65 [inlined]
[21] add at C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.2\Pkg\src\API.jl:65 [inlined]
[22] #add#20(::Base.Iterators.Pairs{Union{},Union{},Tuple{},NamedTuple{(),Tuple{}}}, ::typeof(Pkg.API.add), ::String) at C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.2\Pkg\src\API.jl:64
[23] add(::String) at C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.2\Pkg\src\API.jl:64
[24] top-level scope at C:\Users\User.atom\packages\julia-client\script\boot_repl.jl:21
[25] include at .\boot.jl:328 [inlined]
[26] include_relative(::Module, ::String) at .\loading.jl:1094
[27] include(::Module, ::String) at .\Base.jl:31
[28] exec_options(::Base.JLOptions) at .\client.jl:295
[29] _start() at .\client.jl:464
in expression starting at C:\Users\User.atom\packages\julia-client\script\boot_repl.jl:1

You’re missing part of the stacktrace there, but this doesn’t seem like a Juno specific problem, considering you can’t even clone the registry.

I’m not sure how to see more of message - it starts at [8] (attached screenshot). If this is not a Juno specific problem do you know where I can read about resolving this, keywords I can use to search for resources, or another group of people I can ask for help?

Can you use the Open External REPL command and enter

using Pkg


I did this and something new happened. The progress bar (arrow next to “Fetching”) went up to 100%, and then it gave me the error:

ERROR: SystemError: opening file “C:\Users\User\.julia\registries\General\Registry.toml”: No such file or directory

The stacktrace that was previously cut off is now visible. Next, I tried manually downloading the missing file from the Github repository and putting it in the directory and rerunning. Maybe this was not the right thing to do, but then I get a different error:

ERROR: Unsatisfiable requirements detected for package WebSockets [104b5d7c]: WebSockets [104b5d7c] log:
├─WebSockets [104b5d7c] has no known versions!
└─found to have no compatible versions left with Atom [c52e3926]
└─Atom [c52e3926] log:
├─possible versions are: [0.8.0-0.8.8, 0.9.0-0.9.1, 0.10.0-0.10.2, 0.11.0-0.11.3] or uninstalled
└─restricted to versions * by an explicit requirement, leaving only versions [0.8.0-0.8.8, 0.9.0-0.9.1, 0.10.0-0.10.2, 0.11.0-0.11.3]

I’ve attached a screenshot of the Stacktrace and Error.

I got Juno to work! Thank you so much for your help. I searched my error messages on Google and followed Kristoffer’s suggestion in this thread: Registry.toml missing

For anyone else who might see this thread dealing with the same issue, here is what I did specifically:

  • I deleted entirely the registeries folder in C://Users/User/.julia
  • I opened the External REPL (not sure if it is necessary to open an External one, or if the one in Atom would have worked as well)
  • I ran:

using Pkg

  • I closed and reopened Atom and tried to use Julia. It gave me another error, but it came with instructions on code to run to resolve it.
  • I closed and reopened Atom again and everything is working as expected