PyPlot doesn't work on Atom+Juno

juno
plotting
pyplot
#1

Hi…I’m new to julia and Atom. My system is Mac OS Mojave and the version of my packages are:
48
The problem is that when I use PyPlot in terminal it works perfectly,
14
but doesn’t show any plot when using PyPlot in Atom(neither plot in plot pane or plot window shows up).
38
I’m so confused right now, how could this happen and what should I do to solve it?

0 Likes

#2

You need to uncheck the plot pane option in the Juno settings.

0 Likes

#3

You can also do pygui(true). If you then want a certain plot in the plot pane you can run gcf().

0 Likes

#4

Thank you so much! It worked.

0 Likes

#5

Do you mean this option?
19
I found that it came out the same result no matter the plot pane is enabled or not😢.

0 Likes

#6

You also need to restart Julia after changing that setting, I think.

0 Likes

#7

Thank you for the gcf() hint. I thought PyPlot plots can only be displayed in external windows, but not in the plot pane.

Is there a way to make plots show up in the plot pane automatically? (instead of typing plot(1:3) followed by gcf())

0 Likes