Juno... what happened with plot window and PyPlot support?

#1

I just discovered that Juno has changed:

  • there is no longer a separate Plot window/frame; instead the plot window appears just as any other tabbed file
    –> every time I issue a plot command in my .jl file, Juno switches to view the tabbed plot window
    –> I then have to go back to the .jl file tab and continue to add labels and what not, and Juno jumps back to the tabbed plot window
    –> in the past, the plot was shown in a separate windows, and there was not this constant jumping back and forth between tabbed windows

Anyway, I thought I had done something wrong, and decided to update Juno (there were 3 updates queued up…). After the update process, Julia had disappeared from Juno… effectively reducing Juno to Atom. This happens every time I update Juno…

So I uninstalled Atom, and deleted every Atom directory I could find + re-installed Atom and added the uber-juno package, etc.

No help – the plot window still appears as a tabbed plot window – which makes Juno unusable – I cannot work in an environment where every time I issue a plot command, Juno changes the active window and forces me to manually click on the file tabe to get back to the file window and run more commands…

Another issue… it appears that Juno does not any longer support PyPlot, only GR??? At least, if I use PyPlot pyplot(), nothing is shown in the tabbed plot window, and I get an error message in the Juno console saying something like PyPlot is not supported.

Note, I don’t have anything against GR, but GR is incomplete (there are some things GR doesn’t support), and for my particular use, the result of GR plot is incomplete/wrong:


Observe:

  • no labels on the upper, 3D plot
  • the scaling of the upper plot is wrong

Anyway: have I messed up my set-up?

#2

Juno always had a plot pane, but you can disable that in the julia-client settings. That’ll get you back to having all plots in separate windows, just like what you’d get from a normal REPL (you might need to restart your Julia session though).

That sounds wrong (and is indeed not the case for me – plotting leaves the focus where it was before).

Yeah, that’s unfortunately a known issue.

Hm, in theory that’ll work now, so it should be fixed in Plots.jl. plotlyjs() should work fine though.

#3

The pyplot problem also appears in IJulia… so something has gone wrong … Plots doesn’t work well with PyPlot in my current installation, and this used to work.
**

Juno always had a plot pane, but you can disable that in the julia-client settings. That’ll get you back to having all plots in separate windows, just like what you’d get from a normal REPL (you might need to restart your Julia session though).

I don’t understand what you write. Is “plot pane” what I call “a separate plot window”? I have not touched the “julia-client settings”, so I don’t understand how things have changed.

Also, restarting my Julia session does nothing. This problem also was preserved after I uninstalled Atom, removed all Atom files I could find, re-installed Atom, and added uber-juno.

Anyway, where do I change this? I’m no expert on Atom/Juno, and your description is not clear to me.

julia-client settings

Is that the same as (in Windows) clicking on the julia menu in Atom and choosing settings? If so, where do I go from there?

#4

No, the Plot Pane is what you called the plots tab:

Yes. You’re looking for “Enable Plot Pane” option:

#5

OK… the “Enable Plot Pane” was enabled. I disabled it, and then I got some error messages about Firewall and Qt… eventually the figure was plotted in a separate window. I then enabled it again, and now it seems to work correctly:


What I tried to describe, is that the plot windows showed up in a tabbed file “window” next to the file name in the yellowed area.
I have no idea as to how that happened…

#6

If I now can figure out what is wrong with Plots and PyPlot… the GR backend doesn’t handle my plot as I want it to…