Atom stopped open plots in Julia


#1

Hello!
I’m using Julia and Atom for it, operation system Linux Mint. This morning I pressed “update” button in Atom and typed “] update” in Julia terminal.

So that is all, program is calculating right numbers, but Atom ignores plotting commands. No warnings, no information. REPL behaves exactly like everything is plotting.
Also plotting in Julia terminal still works. So it should be some problems with Juno and Atom I suppose

This warning emerges only if I try to recompile Julia:
[ Info: Precompiling Atom [c52e3926-4ff0-5f6e-af25-54175e0327b1] WARNING: Method definition displayable(Atom.JunoDisplay, Base.MIME{Symbol("application/prs.juno.jlpane")}) in module Atom at /home/mikhail/.julia/packages/Atom/v2iqN/src/display/showdisplay.jl:92 overwritten at /home/mikhail/.julia/packages/Atom/v2iqN/src/display/showdisplay.jl:94. WARNING: could not import Base.endof into StringDistances


#2

Do you still have this problem with the latest version of Juno?


#3

Yes, updated Atom 4 hours ago. I’m thinking just to uninstall everything and install as new. But I do not have time for it and just using terminal to launch my programs.


#4

What plotting package are you using? Can you share a minimal example that doesn’t plot even though you’d expect it to?


#5

as example:

using PyPlot
a=[i*i for i=1:100];
plot(a)

No errors, I have a and PyCallObject in workspace. But no plot.
Than I press in Atom:
Julia -> Open Terminal
and this code (and a little bit more complicated with imshow() and contour() functions) works as usual in this terminal


#6

Ah, PyPlot… Ok, so this happens because only PyPlot.Figures support Julia’s Multimedia API and not normal plots. The following will display the current figure in Juno’s plot pane:

using PyPlot
a = [i*i for i in 1:100]
p = plot(a)
display(gcf())

Alternatively you can just disable the Plot Pane in the julia-client settings and get PyPlot’s native display.


#7

And not forget to restart Atom after disabling it,
It helped.
But I still don’t get how this happened, if everything worked before and I didn’t change anything in settings.

Many Thanks