Plots.jl tiny plots in jupyter-notebook

Pkg upgraded my packages and now all jupyter-notbook plots are tiny. Any idea how to fix this? Capture

1 Like

You need GR 0.34.1. Try ]up

Another question on Plots… With Julia v.0.6.4, I can do using Plots; pyplot() and continue to do plot(…).
With Julia v. 0.7 and v. 1.0, I get some error message/warning about conflicting plot commands, and it appears that I need to use the namespace of PyPlot for it to work.
Question: What is the reason for this change in behavior?

There’s been no such change, and I can’t reproduce this.

I have GR 0.34.1, also tried to rm + add it, but it does not help. Any other ideas?

This happens to me too – with GR v0.34.1, Plots v0.19.3, IJulia v1.11.1 and Julia 0.7.0 on a mac.

I started experimenting with NextJournal and experienced the same issue. I did see an error message about not finding libqt5widgets.so; not sure that is related…

I currently use the following workaround:

gr(size=(500,500), html_output_format=:png)
5 Likes

There’s a related issue in Juno: GR plots inside Atom really small

The workaround doesn’t help me (in Juno) unfortunately…

Did you also do

using PyPlot

? Just remove this, if so.

The html_output_format setting was the only workaround that worked for me using gr in Jupyter (suggested by jw3126). I was seeing the same behavior in IJulia, until I tried this. Previously my fonts were extremely small in the plot and setting them did not do anything.

2 posts were split to a new topic: Plots.jl tiny plots in Jupyter