Math bold font in Windows 10


#1

I tried using \mbfL or \mbfTheta at the REPL in both Julia 0.6.4 and Julia 1.0.0 in Windows 10, but neither of these prints the correct character and instead prints a (very handsome) question mark in a box. In my googling, I found some suggestions to install the Asana and Asana Math fonts, but doing that doesn’t seem to help. I also tried using the Linux REPL and that seems to work just fine, so this appears to be a Windows problem (sigh.)


#2

According to the documentation these should be \bfL and \bfTheta.

If that fails, there is another, more elegant solution to your problem.


#3

I have also tried \bfL and \bfTheta, but to no avail. I can run Ubuntu under VirtualBox on my desktop, but unfortunately can’t escape Windows and would like to be able to run Julia in a non-virtualized environment. Are there any other suggestions?


#4

Sorry for my sarcastic response, but I couldn’t resist. :imp:

It sounds like it is almost definitely a font issue. What shows up, just nothing? I would try experimenting with a few different fonts. I use Monospace Regular mostly because it has terrific unicode support. I would try setting the terminal font to a few different things. (I’m not sure if you can actually do that yet, but I’m pretty sure MS is adding that ability as part of their grand developer courtship initiative.)


#5

Git for Windows comes with Git Bash, a bash-type terminal emulator. If you run Julia from there, unicode will display by default (at least, it displays for me and I can’t recall doing anything to enable it).

However, the characters don’t look like regular math bold from LaTeX. Here’s \theta \Theta \bftheta \bfTheta:
theta


#6

Thanks for the help - the git terminal does show the Unicode fonts right. The suggestion to try some other fonts in the default terminal was a good one, but I couldn’t get \bfL or \mbfL to work correctly in any of the other fonts either. I will keep up hope that improved Unicode support will accompany their apparent recent quest to embrace developers…


#7

Did you try the advice here? https://github.com/JuliaLang/julia/blob/master/README.windows.md#unicode-font-support


#8

Another great suggestion; unfortunately, while the regedit option made it possible to use the Deja Vu Mono Sans font in the console, \mbfL (or \bfL) still only produces wee question marks in boxes. This appears to be quite the troublesome gremlin.