Accents on greek letters in REPL don't seem to work (Julia 1.6.1)

With Julia 1.6.1 on FreeBSD, If I type x\hatTAB in the REPL, I get the expected, i.e. what LaTeX would produce with \hat{x}. But if I try \nuTAB\hatTAB, the hat appears to the right of \nu.

My recollection is that this did not happen with 1.5, maybe not even with 1.6.0.

In the Julia REPL, I’m able to reproduce this unexpected behavior.

But with Windows PowerShell, things works as expected.

It is recommended here

We highly recommend running Julia using a modern terminal, such as installing the Windows Terminal from the Microsoft Store.

1 Like

Sounds like a font issue, nothing to do with Julia per se.

When you invoke start on Julia on Windows via the installed shortcut, it does launch a particular console. Perhaps this could be made configurable so one could use Windows Terminal by default?

Next time I’m on my Windows box, I’ll see if there a way to create a shortcut that launches Julia in Windows Terminal rather than the old console.

1 Like

Let’s not derail this topic with questions about the Windows console (which is particularly bad for Unicode because it doesn’t support fallback fonts). The original poster is on FreeBSD, and so presumably just needs to install a font (e.g. JuliaMono?) that supports the ν̂ glyph.


The Julia REPL operates via a terminal emulator, and there are many different terminal emulators (List of terminal emulators - Wikipedia). You’ll also find them in Atom/Juno and VSCode (they both run the xterm.js Javascript one I think).

Terminal emulators vary a lot in their capabilities, particularly when it comes to rendering text in your selected font. For example, some will let you display ligatures, others won’t. Some can handle diacritic/glyph composition, some can’t. Others are working on improving support for various features, but haven’t got there yet. Others aren’t supporting features for performance reasons. (For example, browse the issues on Alacritty’s GitHub…)

So it looks like the combination of terminal emulator and font you’re using is not performing ideally. Trying various different combinations of terminal emulator and font isn’t everyone’s idea of A Good Time, but it’s probably worth trying a few, if you spend all day looking at it…! :slight_smile:


Thanks. I installed the JuliaMono fonts, and added them to the front of the X server’s font path, but no luck.
By the way, when I use Julia in Emacs through julia-repl, the same problem occurs.

I had to change manually the font on terminal’s preferences to recognize JuliaMono.

I just don’t know how to make it work on VSCode.