LaTeX symbol workaround Windows

I’ve pestered people about this in other discussion venues, but I’ll ask here too. The well documented math symbol support problem with the Julia REPL in Windows CMD isn’t easy to fix for people unaccustomed to messing around with terminal internals etc. Specifically many symbols won’t render, and will just show whatever the missing symbol glyph is for that font. This may be easily fixed by a complete font being used, but I’ve yet to find one.

Could someone post their workaround with detailed instructions? Especially if it lets me use most of the math symbols in the Juno REPL. I couldn’t find a setting to just switch the terminal Juno uses, if it’s possible that’d be great! If there’s a good clear workaround it may be nice to add it to the special symbols section of the Julia Docs, since I know this issue has frustrated more than a couple Windows users.

The new terminal MSFT announced at BUILD might fix this problem eventually, but in the meantime a bandaid of some sort would be much appreciated.

You should be able to simply change the cmd font to “Consolas” (Right click the window bar → Properties → Font → Select Consolas and maybe choose a larger font size).

Afterwards most math symbols should work:


Personally, I use cmder on Windows but probably that’s not what you’re looking for.


Just use Jupyter notebooks or JupyterLab (via IJulia) instead of the raw REPL. See my instructions for my students:

You just need to tell Atom to use a font with good unicode support – Source Code Pro for example looks pretty good:

The workaround I settled on is to run Julia inside Git bash. That allows many more options for fonts as well, like using Fira Code in the REPL. As a bonus, shelling out actually works as expected.

1 Like

Switch to Consolas

That’s definitely better now thanks! Do you know of any TrueType fonts that support the \scr glyphs? That’s rather niche I imagine. Can you change the Juno repl to cmder?

Use Jupyter

I have used Jupyter for Julia before, and it works perfectly! I’d like to stick with Juno for right now, though, so I’m stuck with the default I think.

Atom fonts

The editor actually supports far more glyphs than the REPL does by default, even with the Consolas font. That’s the big issue, if I define some symbol in the editor that doesn’t work with Consolas I have to find and replace all the instances of that symbol with something simpler/different.

Is there a way to set the Julia.exe program to run in Git Bash (or any other terminal) instead of cmd.exe?

Honestly, I never tried. Git bash is Mintty, so you could look online for a command line instruction to start up a specific program when Mintty starts and then edit the shortcut to run Julia that way. I added Julia to my path and just type ‘julia’ to start it inside the console. I often use Git at the same time as Julia, so that works for me. Just hit Ctrl-d in Julia to drop back to Git bash and Ctrl-d again to close the console.

You can do that for the terminal in vscode:

  "": "C:\\Program Files\\Git\\bin\\bash.exe"
1 Like