Juno vs VS Code vs Sublime Text with Julia 1.7

I have been using 1.7 without any trouble. However, Juno doesn’t seem to support it yet I get a “Couldn’t resolve version error.” I keep wanting to switch to VS code but the fuzzy file finding in Juno is deal breaker for me. Since I use TDD I spend a lot time writing test in the test fodler. I can’t get the auto completion to pick my locally defined module in that folder. So until it’s fixed I refuse to use it.

VS Code has fuzzy file hunting as well:

1 Like

I would actually suggest Sublime Text (v.4). Its indexing works flawlessly. Just set up a project, and all symbols, wherever they are, are at your fingertips.


You can still use Juno/Atom with Julia v1.7 - it also works with Julia v1.8β1, fortunately:

I’m also happy staying with Juno/Atom for a bit longer…

1 Like

Any idea why Atom/Juno can’t find launch Julia 1.7.2 on my machine? I am running Manjaro. Julia is added to my path and launches from terminal.

It definitely works fine on Manjaro - have you tried providing the path manually in settings?

Yes I tried that see screen shot.
Is possible the version of atom is at fault? Atom 1.59.0