From Julia version 1.0 to 1.5

I downloaded Julia version 1.5.3 after having used version1.0.4 via Atom till now.
How can I start using 1.5.3 with Atom? Or is a different shell more suitable?

Microsoft stopped further development of Atom, therefore VSCode (with the corresponding Julia plugin) is the more future-proof solution.

Nevertheless, Atom / Juno should work with Julia 1.5.


How can I start using 1.5.3 with Atom?

Your best bet is to install Julia and put the julia.exe on the path. Then both Atom and VSCode can find Julia without any configuring.

Or is a different shell more suitable?

Atom is fine however it is not getting new features according to the video: JuliaCon 2020 | (Juno 1.0) VSCode for Julia 1.0 | Sebastian P., Shuhei K., David A.. VSCode is your best long term bet it seems. Atom works fine today. I use VSCode but have Atom installed too.


Hi Lungben,

I managed to install VSCode with the Julia plugin, and that works.
However, I’m not sure that it uses Julia 1.5.
How can I check the Julia version that’s being used?

Jaap de Gruijter

I had already installed Julia 1.5.3 (after using 0.5, 0.6 and 1.0). But I don’t know how to
“put the julia.exe on the path”

You can do versioninfo() in the Repl in VSCode.

I understand.

  1. You will need the folder that julia.exe is located in your computer.
  2. Follow this how-to to add it to your user path How to add a folder to `Path` environment variable in Windows 10 (with screenshots) - Stack Overflow

I am using a Mac and added the following to the settings file:
“julia.environmentPath”: “Users/jjdegruijter/programs/Julia-1.5/bin/julia.exe”,

I’m still not sure that version 1.5 is actually used though. How can I check that?

I managed to use now Julia 1.5.3 via VSCode. However, each time I run my code with the option “run without debugging”, I get:
“Updating …”, “Updating…”, “Resolving…”, “No changes …”, etc.
and the number in the Julia Debugger is increased by 1.
So is Julia still debugging? The repeated updating and resolving seems unnecessory to me, and timeconsuming.

I am not sure what to say. This seems like a separate issue.

Good job on getting the path updated! I definitely have never updated the path on mac.

If you are on Mac you shouldn’t be using a “julia.exe”, which is for Windows.

1 Like