Juno Error "Can't resolve version"

I am using Manjaro Gnome. I updated to Julia 1.7.2 for some reason this broke Juno. I have completely purged my system of all prior Julia versions and added Julia to my PATH even though pamac does this already. Any help resolving this would be appreciated.

One suggestion I have is to check the path in the Settings. (Installation Instructions · Juno Documentation)

The default path is set to julia ( again I added this to PATH). I have given the Julia Client setting the direct path. “/usr/bin/julia” Same error. You can invoke julia in terminal with this command as well. See screen shot.

Ok, I have one more idea and then I’m out … are you running any automatic startup or config files? (They’re picked up from a .config or .julia/config or somewhere…)


I am not. This is essentially a clean installation. I can check to see if there is any files lying around some where.

I have no more suggestions… All the users and support have gone to VS-Code… :slightly_frowning_face:

Thanks I know. I want to use VsCode but Auto Completion does not work in the test folder. I use TDD so it not picking up my local module is way too annoying. I have been waiting for more that a year for this things to just work in VsCode. I guess dev team doesn’t think it a priority or I am in the minority of use cases. Maybe you have suggestion there?

1 Like

Well I had Atom installed Via FlatPack. I guess that was the problem. I installed the AUR package now it works.