Juno slow then crashes

Juno is being super slow lately. When I type in the REPL it shows some partial results, then it takes some time (15 or 20 seconds, easily) and then it finishes showing the results.

Furthermore, when I try to run a function (simple function, it just takes a bunch of Tuples and return another Tuple) it gets an error
Error displaying Tuple{…} ReadOnlyMemomryError()
and the Atom completely crashes.

Any ideas about what might be going on?

update: the ReadOnlyMemoryError() was my mistake, but Juno is still pretty slow and sometimes crashes.

If this is happening for all input, then try the “Fallback Renderer” option in julia-client > Settings > Console Options.

If not (or that doesn’t help), then I’m not sure what is going on – is the rest of the editor slow as well? Is 1+1 in the REPL slow? Can you share some more details about your system, or maybe a video of what’s going on? Do you have anything in startup.jl or juno_startup.jl? Can you share Juno’s debug info (which you can get with Julia Client: Debug Info?

“Fallback Renderer” is enabled (I had it enabled before).

This is the video https://drive.google.com/file/d/1vAGaRoaoWrNiH1NFQZl9_xBvgi61B49g/view?usp=sharing
I run a few lines. You can see how long it takes to process simple lines of codes (the functions are really simple). Then I try to show in the REPL the variable “sol_college_all[i]” and I even get messages that the editor is not responding.

By the way, I’m using Julia 0.6.4 (the codes are old and I never updated them). I’m running on a Macc processor Intel i7 1.7 GHz, Memory 8GB 1600MHz DDR3.

I don’t think I have the files startup.jl or juno_startup.jl I could not find them.
Where should I run Julia Client: Debug Info ?? I did not get that, sorry.

Wow, that looks really obnoxious. I think the problem here is the Workspace pane, which can slow don’t Atom a lot under some circumstances.
It’s really unfortunate that you’re using Julia 0.6 still, because that bug should be fixed with the latest release of Atom.jl – but that is on Julia 1.0 only…
For completeness: What versions of julia-client and ink are you running?

I guess I could backport some crucial bugfixes so they’d work on 0.6, but I suspect there’s only a few people left running older Julia versions. In the meantime you should be able to work around these issues by

  • closing the workspace pane and
  • making sure you don’t display the results of those computations by ending the line with a ;

I’m using julia-client 0.9.4 and ink 0.10.12.

Closing the workspace pane helps A LOT!!
It does not crash anymore. Thank you.

1 Like