Atom / Juno Crashes

juno

#1

Since yesterday, when I use Atom + Juno (inline evaluation, plotting from Atom etc) my laptop completely freezes every 20 minutes or so - this is causing all sort of havoc with my system (e.g. I had to completely reset docker) so I need to stop using julia-client. This has only happened with Atom+Juno when using Julia-client and in no other context, e.g. when I use Atom+Juno just as an editor.

Has anybody else experienced this?

If either yes/or no: can anybody suggest what is going wrong so I might avoid a complete re-install of Julia, Atom, Juno?

My system:

  • MacBook Pro 2017, 10.12.6
  • Atom 1.18.0
  • Julia-client 0.6.0
  • Julia 0.5.2 (compiled from source)
Julia Version 0.5.2
Commit f4c6c9d4bb* (2017-05-06 16:34 UTC)
Platform Info:
  OS: macOS (x86_64-apple-darwin16.7.0)
  CPU: Intel(R) Core(TM) i7-7820HQ CPU @ 2.90GHz
  WORD_SIZE: 64
  BLAS: libgfortblas
  LAPACK: liblapack
  LIBM: libopenlibm
  LLVM: libLLVM-3.7.1 (ORCJIT, broadwell)

#2

Can you update to Julia 0.6? If not you’ll probably need to roll back to julia-client 0.5.2.


#3

Thank you for the suggestion. Unfortunately I have too much 0.5 code and not enough time to upgrade. I will try to downgrade Julia-client and return here if I run into problems.


#4

But independently of whether this will fix t for me: how is it possible that a complete system freeze occurs?


#5

No idea – I’d suspect some kind of memory issue (maybe related to the Workspace pane), which might or might not be fixed when using Juno on Julia 0.6 or at least using Juno 0.5 and Julia 0.5 together.
Btw, the command for using a specific package version is apm install package@version. You should probably also downgrade to an older ink version, but not sure.

If all that doesn’t work I can look into debugging this further some time tomorrow though.


#6

Can I just confirm that I should be using julia-client@0.5.12? apm doesn’t find julia-client@0.5.2


#7

I will try this tonight and report back whether or not I had more problems.


#8

Yeah, latest 0.5 should be correct.


#9

This seems to have fixed it - I worked all night without problems. Thank you.