Julia 0.7 juno's julia console very slow


#1

I just migrated to julia 0.7. Deleted all my atom packages (removed ~/.atom) and installed juno again from the atom package manager.

Now I get a very slow julia console in atom/juno: I have to wait a few seconds after I press any key for the character to appear on the julia console. This on linux x64. Looking at the CPU usage on my machine, it is very low so this is not the problem.

Anyone else having this problem? Is there a fix?

Thank you


#2

Does this happen every time you start up, or just the first time? The first time a bunch of stuff needs to get precompiled etc so I’m not surprised it takes a while. But mine is pretty snappy (on a Mac with Julia 1.0)


#3

Try enabling the fallback renderer in julia-clients console settings, that should massively help with performance.


#4

Thank you. With the fallback renderer, the console is usable again.


#5

I tried the fallback renderer and restarted but it didn’t help. I then unchecked the boxes for enable menu, enable toolbar, and enable plots pane, and now it is fine.


#6

That seems very weird – do you still see performance problems when you re-enable those checkboxes but don’t touch the renderer setting?


#7

No, no performance problems with a re-enable.

I might have found my problem. It seems restarting Atom is not enough to change the setting. I had to hit x on the console, restart Atom, and then issue the Open Console command.

I learned this because unchecking the fallback renderer option also didn’t cause any performance problem initially after a restart. The performance problems came back after I manually closed the console and reopened it.

It’s possible I manually closed the console after I unchecked the enable menu boxes.