Can't start Julia through Juno

I can’t start Julia through Juno.
I uninstalled, reinstalled, tried out different version of Julia, changed the path and nothing worked so far.
Could please anyone give me an advice?

Thank you!

Which versions of the Atom packages (julia-client and ink) and Julia packages (Atom and Juno) are you on? What’s the path to your Julia executable? What happens when you paste that path into a shell and try to run Julia?

1 Like

Sorry, I tried changing the Julia path and it seemed like it worked! Thank you so much to offer help :slight_smile:

It was working until a couple weeks ago and it stopped working again.
Julia runs through Shell when I use the external terminal in the Boot mode but the Basic doesn’t work anymore for some reason.
I’m using Julia 1.1 and updated Atom and Juno, I believe.

2020年10月6日(火) 3:50 Nils via JuliaLang <julialang@discoursemail.com>:

Why are you using Julia v1.1? The latest release is 1.5.2. The problem you describe sounds like an issue that might be solved by just re-installing the julia client package in Atom.

Hi, thanks for getting back to me. I’m using the older version because the code provided my prof is based on 1.1…
I reinstalled the Julia client and it works now. Thank you!!

FWIW, updates are a bit wonky, so I’d recommend following the instructions at http://docs.junolab.org/latest/man/update/ the next time.