Issue with 'stuck' font in Juno/Atom

I have an issue with Juno that is perhaps an Atom issue, but I’m not sure.

The font selection for the editor pane is stuck at the Hasklig font. I used that some months ago, but then wanted to change to a different one. When I change fonts in Settings → Font Family, the fonts are correctly updated in the Juno REPL and also in the workspace pane, but for some reason not in the editor pane.

I’m on a Mac, and have even tried to disable the Hasklig font in Font Book, which should make it unavailable for all apps, but it’s still there inside the Atom editor pane, after a restart. This behaviour has persisted across several Atom/Juno updates, and I’m now using the latest version of both.

Perhaps this is more properly an Atom issue, but the weirdness of the interaction with the REPL/workspace panes, made me want to ask here first.

Can you open the Electron dev tools via Ctrl-Shift-I, click on the Select an element in the page to inspect it button and then click on some text in an editor, then click on “Computed” on the right and post a screenshot of the expanded font-family entry?
Also, check your stylesheet (via Application: Open Your Stylesheet) – there might be something like

atom-text-editor {
  font-family: Hasklig !important;

in there, which would explain those issues.

Here’s the screenshot.

The styles.less file had this empty entry:

.atom-text-editor {


I’ve been trying to change the font to Fira Code which shows up with a strike-through.

Can you tell me where clicking on the top-most <style>...</style> takes you?

Clicking on that <style>...</style> was a bit confusing. Not sure exactly what happened.

I managed to solve the problem anyway. It turns out that I had installed a package “atom-hasklig” which apparently overrode the font settings. When I disabled that package, font settings started to behave reasonably.

It seems like the package was necessary to enable font ligatures for Hasklig, while ligatures work by default for Fira Code.