Difficulty compiling in Atom

Hello everybody

I installed julia and it’s working, but I can’t compile anything, it’s like the IDE (Atom) isn’t seeing any commands I give.
Has it ever happened to anyone?
What should I do?


Hi Raquel,

Please provide more information as to what you are doing and you are expecting to happen versus what actually happens.

What do you mean when you say you can’t compile anything? What commands are you giving?

We can help you much better if we know more specifics :slight_smile:

1 Like

Also, note that the Atom support for Julia is pretty outdated by now, and Atom has even been discontinued as an editor by its owners Microsoft/Github. Nowadays, VS Code with the Julia extension is the recommended IDE for development.


Hi @jacobusmmsmit , thanks for answering me

I’m trying to do simple things like:

a = 1
b = 3
c = a+b

I hit Ctrl + Enter on each line and it’s like nothing happens

How did you install Juno? Did you use uber-juno?

1 Like

Hi @nilshg

Yes, I used uber-juno

Is Atom aware of the path to your julia executable?
I can only second the advice of @digital_carver to switch to VSCode though, the extension for Julia works like a charm

Yes it is. Well, I’m thinking of migrating to VSCode

1 Like

If you followed the Juno installation instructions (sounds like you did), it should work. Did you try restarting your computer?

Hey @Nathan_Boyer

I tried yes, and it didn’t work :frowning:

Hey @digital_carver

Thanks for the tip!

1 Like

Did you get any errors? I just tried a clean install and it failed for me as the indent-detective package couldn’t be found