Use IJulia after updating Julia version

I would like to use IJulia notebook with Julia 1.6.0 beta1. However, it does not show up in the list of available kernels. Is there a way to add it to the list? Thanks!

2 Likes

You need to install IJulia package for that:
] add IJulia

I have installed IJulia via Julia 1.6, but it does not show up. Is there an additional step that I am missing?

Maybe need to build it:
] build IJulia

1 Like

That was the problem. Thank you!

IMHO, it’s complicated. Jupyter/Python needs to be able to find Julia, so
~/Library/Jupyter/kernels/julia-1.6/kernel.json (on MacOS)
needs to contain correct paths to match Julia 1.6. This is when you start Jupyter first, then Julia.

And IJulia needs to be able to find jupyter. This is when you first start Julia, then Jupyter. This is currently broken for me. Julia is trying to find Python in the old location which no longer exists. I think this is what the JUPYTER environment variable is for, but changing that didn’t help.

I’ve been here a lot of times, Python and Julia end up being out of sync. I’m usually using Jupyter lab.

I think I had a similar problem before. What worked for me was uninstalling Python and installing Anaconda during the IJulia setup phase. But perhaps you already tried that.

After changing env variables you usually have to build a package again. That’s the case for IJulia, PyCall packages I guess, when changing related env variables.

I don’t care, not today. My usual fix for this is to re-install Julia by first uninstalling it with

sudo rm -rf ~/.julia